Max Sum

A - Max Sum
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Practice

HDU 1003

Description

Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

这道题是看的网上的代码敲的,之后不知怎么wa,之后找到了,在代码上看吧:

#include<iostream>
#include<cstring>
using namespace std;
const int maxn=100000+1;
int  main()
{
    int t;
    cin>>t;
    int a[maxn];
    int d[maxn];
    int k=1;
    int n;
    while(t--)
    {
        memset(d,0,sizeof(d));
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i];
        d[1]=a[1];
        for(int i=2;i<=n;i++)
        {
            if(d[i-1]<0)d[i]=a[i];
            else d[i]=d[i-1]+a[i];
        }
        int max1=d[1];
        int end1=1;
        for(int i=2;i<=n;i++)
        {
            if(d[i]>max1)//开始的时候是d[i]写成a[i]了,原来的endl也没有赋值,使得后面的endl在循环中也没有杯赋值,所以程序开始的时候老意外终止。
            {
                max1=d[i];
                end1=i;
            }
        }
        int sum=0;
        int start=end1;//
//        cout<<"Case "<<k++<<":"<<endl;
//        cout<<max1<<" "<<start<<" "<<end1<<endl;
        for(int i=end1;i>=1;i--)
        {
           sum+=a[i];
           if(sum==max1)
                {
                    start=i;
                }
        }
        cout<<"Case "<<k++<<":"<<endl;
        cout<<max1<<" "<<start<<" "<<end1<<endl;
        if(t)
            cout<<endl;
    }
    return 0;
}
//后面改完了这个问题之后,提交上去就是wa,后面自己测试了一下,如  3 -1 -2 -3 结果是-1 3 3 ,后面我想了一下,原来是当初endl定义的时候赋值是n,后面改成1之后就ac了
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值