HDU1114 Piggy-Bank(完全背包)

Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
 

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 

Sample Input
  
  
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
  
  
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
 

首先了解一下完全背包

完全背包(CompletePack): 有N种物品和一个容量为V的背包,每种物品都有无限件可用。第i种物品的费用是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的费用总和不超过背包容量,且价值总和最大。

这个问题非常类似于 01 背包问题,所不同的是每种物品有无限件。也就是从每种 物品的角度考虑,与它相关的策略已并非取或不取两种,而是有取 0 件、取 1 件、取 2 件……直至取 ⌊V /Ci⌋ 件等许多种。

参照01背包状态转移方程可以写出如下状态转移方程:

F[i,v] = max{F[i−1,v−kCi] + kWi |0 ≤ kCi ≤ v};

同样地,完全背包也能用一维数组的存储方式实现,只要内循环从逆序变为顺序就可以了。

状态方程同样为:F[i,v] = max{F[i−1,v],F[i,v−Ci] + Wi}

为什么改为顺序就可以了呢?

为了对比01背包,我同样地列了一张表。

01背包:


完全背包:


不难发现,01背包中内循环逆序保证了每件物品只使用一次,F[i,v-ci]中没有使用过第i件物品的状态,而改为顺序后,F[i,v-ci]就可能存在使用过第i件物品的状态。

至此,完全背包就讲完了。

完整的基础版完全背包代码如下:

#include<iostream>  
#include<cstring> 
using namespace std;   
int main(void)  
{  
	int i,j,n,m,W[4000],D[4000],dp[13000];  
	cin>>n>>m;  
	memset(dp,0,sizeof(dp));  
	for(i=1;i<=n;i++)  
		cin>>W[i]>>D[i];  
	for(i=1;i<=n;i++)  
		for(j=W[i];j<=m;j++)  
		{
            dp[j]=max(dp[j],dp[j-W[i]]+D[i]);  
			
		}

	cout<<dp[m]<<endl;  
	return 0;  
}   

再来看这道题,由于要求最小价值,那么max换成min就行了。还要注意dp初始化为大数,但dp[0]要为0。

代码如下:

#include<iostream> 
#include<cstdio>
#include<cstring> 
#include<algorithm>
const int INF=0x3f3f3f3f;
using namespace std;   
int main(void)  
{  
	int t,W[505],D[505],dp[10005];  
	scanf("%d",&t);
	while(t--)
	{
		int n,m,e,f;
	    scanf("%d%d",&e,&f);
		m=f-e;
		scanf("%d",&n);
     	memset(dp,INF,sizeof(dp));  
	    for(int i=1;i<=n;i++)  
			scanf("%d%d",&D[i],&W[i]);
		dp[0]=0;
	    for(int i=1;i<=n;i++)  
		    for(int j=W[i];j<=m;j++)  
                dp[j]=min(dp[j],dp[j-W[i]]+D[i]);  
		if(dp[m]==INF)
			printf("This is impossible.\n");
		else
			printf("The minimum amount of money in the piggy-bank is %d.\n",dp[m]);
	}
	return 0;  
}   

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值