Beat
Time Limit: 6000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2441 Accepted Submission(s): 1395
Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
Output
For each test case output the maximum number of problem zty can solved.
Sample Input
3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
Sample Output
3 2 4
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
题目大意:
一个人解决问题有个习惯,就是只解决比上一次花费时间长的问题,问他最多能解决多少题。
分析:这道题用dfs,但是为什么用dfs,我说下自己的想法,这道题给出了问题的个数,说明我搜索树最深就是问题的个数,而他问我最多能解决多少问题,也就是在问我树的深度,而bfs一般是找最小代价,也就是在搜索树中找深度的最小值。所以这道题应该用dfs。通过题目中说的Tij代表解决问题i后解决问题j花的时间。就知道了我的搜索顺序是每次以j为行,对每列去进行判断搜索。
代码:
#include<iostream>
#include<string.h>
using namespace std;
int n;
int ans;
int maze[20][20];
int vis[20];
void DFS(int h, int r, int dep) {
for (int i = 0; i < n; i++) {
//当前问题没有被回答过并且比上一题难
if (!vis[i]&&i!=r&&maze[h][r]<=maze[r][i])
{
vis[i] = 1;
DFS(r,i,dep+1);
vis[i] = 0;
}
}
if (ans < dep) {
ans = dep;
return;
}
}
int main() {
while (cin>>n)
{
memset(vis, 0, sizeof(vis));
for (int i = 0; i < n; i++)
{
for (int j = 0; j < n; j++) {
cin >> maze[i][j];
}
}
//题目中的意思是他解决第0个问题花费0时间,但给的数据可能不是0
maze[0][0] = 0;
vis[0] = 1;
DFS(0, 0, 1);
cout << ans << endl;
ans = 0;
}
return 0;
}