hdu 5944 Fxx and string


Problem Description
Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string  S  contains  n  lowercase letters  S1S2Sn .Now Fxx wants to know how many three tuple  (i,j,k)  there are which can meet the following conditions:

1、 i,j,k  are adjacent into a geometric sequence.

2、 Si= ' y ' ,Sj= ' r ' ,Sk= ' x '.

3.Either j|i or j|k
 

Input
In the first line, there is an integer  T(1T100)  indicating the number of test cases.

T  lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed  10000 ).
 

Output
For each case, output the answer.
 

Sample Input
  
  
2 xyyrxx yyrrxxxxx
 

Sample Output
  
  
0 2
 

Source
 


这道题我被hack了等比数列,递增的和递减的都可以,我只考虑了一面

#include<bits/stdc++.h>
#include<stdio.h>
#include<iostream>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        char ss[10010];
        scanf("%s",ss);
        int len=strlen(ss);
        for(int i=len; i>=1; i--)
        {
            ss[i]=ss[i-1];
        }
        ss[0]='0';
        int sum=0,a1,a2,a3;
        for(int i=2; i*i<=len; i++)
        {
            for(int j=1; j<=len; j++)
            {
                a1=j;
                a2=a1*i;
                a3=a2*i;
                if(a3<=len&&ss[a1]=='y'&&ss[a2]=='r'&&ss[a3]=='x')
                {
                    sum++;
                }
            }
        }
        for(int i=2; i*i<=len; i++)
        {
            for(int j=1; j<=len; j++)
            {
                if(j%(i*i)==0)
               {
                    a1=j,a2=a1/i,a3=a2/i;
                    if(a3>=1&&ss[a1]=='y'&&ss[a2]=='r'&&ss[a3]=='x')
                    {
                        sum++;
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值