hdu 5317 RGCDQ

Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know maxGCD(F(i),F(j)) (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line.
See the sample for more details.
 

Sample Input
  
  
2 2 3 3 5
 

Sample Output
  
  
1 1
 

给l,r让求 max ( gcd ( f(i) ,f(j) ) ) f(x) 表示不同的素因子个数 我们知道(2*3*5*7*11*13*17=510510) 所以最大的公因数在1到7之间


#include <iostream>
#include <cstdio>
#include <cmath>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
#include <map>
#include <set>
#include <stack>
#include <vector>
#include <sstream>
#define PI acos(-1.0)
#define eps 1e-8
#define f 1000010
const int  inf =  (1<<30) - 10;
const int N=1000010;
using namespace std;
int prime[N];
int dp[N][9];
void table()
{
    for(int i = 2; i < N; i++) //循环到N打表,求出所有数的素因子个数
        if(prime[i] == 0)
        {
            prime[i]++;
            for(int j = i * 2; j < N; j += i)
                prime[j]++;
        }
    for(int i = 2; i < N; i++)
        for(int j = 1; j < 8; j++)
        {
            if(prime[i] == j) dp[i+1][j] = dp[i][j] + 1;
            else dp[i+1][j] = dp[i][j];
        }
}
int main()
{
    //freopen("input.txt","r",stdin);
    table();
    int T;
    cin>>T;
    int l, r;
    while(T--)
    {
        scanf("%d %d",&l,&r);
        int knum[8];
        for(int i = 1; i <8; ++i)
        {
            knum[i] = dp[r+1][i] - dp[l][i];
        }
        if(knum[7] >= 2)
        {
            printf("7\n");
        }
        else if(knum[6]>=2)
        {
            printf("6\n");
        }
        else if(knum[5]>=2)
        {
            printf("5\n");
        }
        else if(knum[4]>=2)
        {
            printf("4\n");
        }
        else if(knum[3]>=2)
        {
            printf("3\n");
        }
        else if(knum[6] && knum[3])
        {
            printf("3\n");
        }
        else if(knum[2]>=2)
        {
            printf("2\n");
        }
        else if(knum[6] && knum[2])
        {
            printf("2\n");
        }
        else if(knum[4] && knum[2])
        {
            printf("2\n");
        }
        else
        {
            printf("1\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值