Prison Transfer~解题报告

Prison Transfer

题目描述:

The prison of your city has n prisoners. As the prison can’t accommodate all of them, the city mayor has decided to transfer c of the prisoners to a prison located in another city.

For this reason, he made the n prisoners to stand in a line, with a number written on their chests. The number is the severity of the crime he/she has committed. The greater the number, the more severe his/her crime was.

Then, the mayor told you to choose the c prisoners, who will be transferred to the other prison. He also imposed two conditions. They are,

The chosen c prisoners has to form a contiguous segment of prisoners.
Any of the chosen prisoner’s crime level should not be greater then t. Because, that will make the prisoner a severe criminal and the mayor doesn’t want to take the risk of his running away during the transfer.
Find the number of ways you can choose the c prisoners.

Input:

The first line of input will contain three space separated integers n (1 ≤ n ≤ 2·105), t (0 ≤ t ≤ 109) and c (1 ≤ c ≤ n). The next line will contain n space separated integers, the ith integer is the severity ith prisoner’s crime. The value of crime severities will be non-negative and will not exceed 109.

Output:

Print a single integer — the number of ways you can choose the c prisoners.

Sample Input:

4 3 3
2 3 1 1

Sample Output:

2

Sample Input:

1 1 1
2

Sample Output:

0

Sample Input:

11 4 2
2 2 0 7 3 2 2 4 9 1 4

Sample Output:

6

题目描述:

这道题讲的是有一所监狱新来了n个犯人,但是监狱空间有限,容纳不了,需要在其中抽出c个人出来转到其他监狱,但是抽人的时候不是随便抽,必须满足以下2个条件

  1. 必须抽出来的犯人之间是相邻的
  2. 所抽出来的犯人不能大于犯罪值(题目会给)
    那么有多少种方法抽出c名犯人。

思路分析:

这道题如果慢慢读就很简单,只在连续区间内不大于犯罪值就行了,这里的连续区间指的是,在犯罪值以下的连续区间,一旦超过,需要重头来抽人,当抽的人达到c的时候,方法加1.

代码:

#include<iostream>
#include<cstdio>
#include<map>
#include<vector>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
	int t,n,c,num;
	while(cin >> n >> t >> c)
	{
		int ans=0,num1=0;
		while(n--)
		{
			scanf("%d",&num);
			if(num>t)
			{
				num1=0;
			}
			else
			{
				num1++;
				if(num1>=c)
				{
					ans++;
				}
			}
		}
		cout << ans << endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值