1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 70970    Accepted Submission(s): 38965


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
17
41

代码
#include <iostream>
#include <string>

using namespace std;

int main()
{
	int n;
	int a[105];
	while (cin >> n&&n != 0)
	{
		int sum = 0;
		cin >> a[0];
		sum = sum + a[0] * 6 + 5;
		for (int i = 1; i < n; ++i)
		{
			cin >> a[i];
			if (a[i] > a[0])
				sum = sum + (a[i] - a[0]) * 6 + 5;
			else
				sum = sum + (a[0] - a[i]) * 4 + 5;
			a[0] = a[i];
		}
		cout << sum << endl;
	}
	return 0;
}


对于这个题,我唯一的感触就是——学好英语是重中之重!!!反反复复看了n遍题目,死活得不到想要的答案,后来突然通了窍,原来每行第一个数字代表的是这一组数据一共有几个数字。了解题意后就会发现是水题,没啥好说的

在某种程度上来说,了解题意比做题更重要(这次蓝桥就好几个题审错提议,写的答案风马牛不相及)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值