8数码 HDU-Eight (A*算法+bfs+康托展开+优先队列)

                                               Eight

                                               Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                     Total Submission(s): 28098    Accepted Submission(s): 7473

                                                                                                    Special Judge


Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x

where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->

The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
 

Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8
 

Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
 

Sample Input
 
 
2 3 4 1 5 x 7 6 8
 
Sample Output
 
 
ullddrurdllurdruldr


A*算法:这儿讲得很好

http://sh.qihoo.com/pc/detail?url=http%3A%2F%2Fzm.news.so.com%2F801d781eb0f8c3ec1170adc50328bb9c&check=74da52006d1963b8&sign=baike

康托展开:   http://blog.csdn.net/axiqia/article/details/51346404


定理:一个排列中的任意两个元素对换,排列改变逆序数的奇偶性


在与空白交换过程中,数码的逆序数不变。

左右交换,逆序数不变;上下交换,某个数字移动两位,逆序数不变。



#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
using namespace std;
struct Node
{
	int mp[3][3];
	int x,y;
	int h,g;//h:距目标还有多远  g:走了多少步 
	int hash;//此时数码序列在整个全排列中的次序,即hash值 
	bool operator < (const Node A)const//优先队列的比较方式 重载 < 
	{
		if(A.h!=h) return A.h<h;
		else return A.g<g;
	}
	bool check()//检查交换是否合法 
	{
		if(x>=0&&x<3&&y>=0&&y<3)
		return true;
		return false;
	}
}u,v;
int vis[400000];//记录交换方式 
int pre[400000];//记录前一个数码序列的hash值 
int dir[4][2]={0,1,0,-1,1,0,-1,0};
int Hash[]={1,1,2,6,24,120,720,5040,40320,362880};
int get_hash(Node temp)//康托展开,计算数列的hash值 
{
	int a[9],k=0,count=0;
	for(int i=0;i<3;i++)
		for(int j=0;j<3;j++)
			a[k++]=temp.mp[i][j];

	for(int i=0;i<9;i++)
	{
		int sum=0;
		for(int j=i+1;j<9;j++)
		if(a[i]>a[j]) sum++;
		count+=sum*Hash[9-i-1];
	}
	return count+1;
}
int get_h(Node temp)//估价函数 ,每个数字到目标位置的距离,曼哈顿距离
{
	int count=0;
	for(int i=0;i<3;i++)
		for(int j=0;j<3;j++)
		 	if(temp.mp[i][j])
				count+=abs(i-(temp.mp[i][j]-1)/3)+abs(j-(temp.mp[i][j]-1)%3);
	return count;
}
bool judge(Node temp)//判断是否有解 
{
	int a[9],k=0,count=0;
	for(int i=0;i<3;i++)
		for(int j=0;j<3;j++)
			a[k++]=temp.mp[i][j];
	
	for(int i=0;i<9;i++)
		for(int j=i+1;j<9;j++)
			if(a[i]&&a[j]&&a[i]>a[j])
				count++;
	return count&1;
}
void print()
{
	string str;
	str.clear();
	int start=46234;
	while(pre[start]!=-1)
	{
		if(vis[start]==0) str+='r';
		else if(vis[start]==1) str+='l';
		else if(vis[start]==2) str+='d';
		else if(vis[start]==3) str+='u';
		start=pre[start];
	}
	for(int i=str.size()-1;i>=0;i--)
	cout<<str[i];
	cout<<endl;
}
void bfs()
{
	memset(vis,-1,sizeof(vis));
	memset(pre,-1,sizeof(pre));
	priority_queue<Node> q;
	q.push(u);
	vis[u.hash]=-2;		
	while(!q.empty())
	{
		u=q.top();
		q.pop();
		for(int i=0;i<4;i++)
		{
			v=u;
			v.x+=dir[i][0];
			v.y+=dir[i][1];
			if(v.check())
			{
				swap(v.mp[v.x][v.y],v.mp[u.x][u.y]);
				v.hash=get_hash(v);
				if(vis[v.hash]==-1)
				{
					v.h=get_h(v);
					v.g++;
					vis[v.hash]=i;
					pre[v.hash]=u.hash;
					q.push(v);
				}
			}
			if(v.hash==46234)
			{print();return ;}
		}
	}
}
int main()
{
	char ch[50];
	while(cin>>ch[0])
	{
		for(int i=1;i<9;i++)
		cin>>ch[i];
		for(int i=0;i<3;i++)
			for(int j=0;j<3;j++)
				if(ch[i*3+j]=='x')
					{u.mp[i][j]=0,u.x=i,u.y=j;u.g=0;}
						else
							u.mp[i][j]=ch[i*3+j]-'0';
		u.h=get_h(u),u.hash=get_hash(u);
		if(u.hash==46234)
		{cout<<endl;continue;}
		
		if(!judge(u)) bfs();
		else cout<<"unsolvable"<<endl;
	}
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值