HDU 2141 二分

http://acm.hdu.edu.cn/showproblem.php?pid=2141

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

题目大意:给你三个数组L,N,M,再给你S个数,设其中某个为X,问你能否从数组L,N,M中各找一个数使他们之和等于X,如果可以的话,输出YES,否则输出NO。

思路:开辟一个新的数组储存任意两个数组的所有和,时间复杂度O(n^2)。对该数组进行排序,然后遍历第三个数组,对于第三个数组的每一个元素,在该数组中进行二分搜索,看该数组中是否存在一个数满足他们的和等于X。总时间复杂度应该是O(n^2lgn)。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<set>
#include<algorithm>
#include<iterator>
#define EPS 1e-12
#define INF 0x3f3f3f3f
using namespace std;

int l[505];
int m[505];
int n[505];
int mn[505*505];

int main()
{
	int t1,t2,t3;
	int times=0;
	while(~scanf("%d %d %d",&t1,&t2,&t3))
	{
		set<int> s;
		int MIN=INF,MAX=0;
		for(int i=0;i<t1;i++)
			scanf("%d",&l[i]);
		for(int i=0;i<t2;i++)
			scanf("%d",&m[i]);
		for(int i=0;i<t3;i++)
			scanf("%d",&n[i]);
		int k=0;
		for(int i=0;i<t2;i++)
			for(int j=0;j<t3;j++)
				mn[k++]=m[i]+n[j];
		sort(mn,mn+k);
		int t,temp;
		scanf("%d",&t);
		printf("Case %d:\n",++times);
		while(t--)
		{
			int flag=0;
			scanf("%d",&temp);
			for(int i=0;i<t1;i++)
			{
				int t=lower_bound(mn,mn+k,temp-l[i])-mn;
				if(t!=k&&mn[t]+l[i]==temp)
				{
					flag=1;
					break;
				}
			}
			if(flag)
				printf("YES\n");
			else
				printf("NO\n");
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值