HDU 2852 树状数组+二分查询

http://acm.hdu.edu.cn/showproblem.php?pid=2852

For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations. 

Push: Push a given element e to container 

Pop: Pop element of a given e from container 

Query: Given two elements a and k, query the kth larger number which greater than a in container; 

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem? 

Input

Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values: 
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container. 

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container   

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number. 

Output

For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".

Sample Input

5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4

Sample Output

No Elment!
6
Not Find!
2
2
4
Not Find!

题目大意:三种操作,p=0,表示在序列中插入e,p=1表示从序列中删除e,若e不存在则输出“No Elment!”,p=2表示从序列中找到大于a的第k个数,若没有输出“Not Find!”。

思路:权值树状数组+二分。

关于权值树状数组的介绍:https://blog.csdn.net/xiji333/article/details/88537527

利用了神奇的find_kth函数,在上面的博客里面有详解:(二分查询的代码在下面)

#include<iostream>
#include<cstring>
#include<cstdio>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

const int maxn=100000;

int cnt[100005];

inline int lowbit(int x)
{
	return x&(-x);
}

int getsum(int v)//小于等于v的元素的数目
{
	int s=0;
	for(;v;v-=lowbit(v))
		s+=cnt[v];
	return s;
}

void update(int v,int num)//将值为v的元素增加num个
{
	for(;v<=maxn;v+=lowbit(v))
		cnt[v]+=num;
}

int find_kth(int k)
{
	int ans=0,sum=0,i;
	for(int i=20;i>=0;i--)
	{
		ans+=(1<<i);//答案一定可以表示成二进制数的形式
		if(ans>=maxn||sum+cnt[ans]>=k)//寻找小于k的最大的ans
			ans-=(1<<i);
		else
			sum+=cnt[ans];
	}
	return ans+1;//ans是小于k的最大的数 那么ans+1必定是第k大的数
}

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		memset(cnt,0,sizeof(cnt));
		int p;
		while(n--)
		{
			scanf("%d",&p);
			if(p==0)
			{
				int e;
				scanf("%d",&e);
				update(e,1);
			}
			else if(p==1)
			{
				int e;
				scanf("%d",&e);
				if(getsum(e)-getsum(e-1)==0)//若e存在 则getsum(e)-getsum(e-1)至少为1
					printf("No Elment!\n");
				else
					update(e,-1);
			}
			else
			{
				int a,k;
				scanf("%d %d",&a,&k);
				int temp=getsum(a);
				if(getsum(maxn)-temp<k)//getsum(maxn)=当前序列元素个数
				{
					printf("Not Find!\n");
					continue;
				}
				k+=temp;
				printf("%d\n",find_kth(k));
			}
		}
	}
	return 0;
}

 二分查询:

#include<iostream>
#include<cstring>
#include<cstdio>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

const int maxn=100000;

int cnt[100005];

inline int lowbit(int x)
{
    return x&(-x);
}

int getsum(int v)//小于等于v的元素的数目
{
    int s=0;
    for(;v;v-=lowbit(v))
        s+=cnt[v];
    return s;
}

void update(int v,int num)//将值为v的元素增加num个
{
    for(;v<=maxn;v+=lowbit(v))
        cnt[v]+=num;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(cnt,0,sizeof(cnt));
        int p;
        while(n--)
        {
            scanf("%d",&p);
            if(p==0)
            {
                int e;
                scanf("%d",&e);
                update(e,1);
            }
            else if(p==1)
            {
                int e;
                scanf("%d",&e);
                if(getsum(e)-getsum(e-1)==0)
                    printf("No Elment!\n");
                else
                    update(e,-1);
            }
            else
            {
                int a,k;
                scanf("%d %d",&a,&k);
                int temp=getsum(a);
                if(getsum(maxn)-temp<k)
                {
                    printf("Not Find!\n");
                    continue;
                }
                int l=a;
                int r=maxn;
                while(l<=r)
                {
                    int mid=(l+r)>>1;
                    int t=getsum(mid);
                    if(t-temp<k)
                        l=mid+1;
                    else
                        r=mid-1;
                }
                printf("%d\n",l);
            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值