http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1709
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2
题目大意:找@连通块的个数,无论是水平、垂直、还是对角线上相邻的,都可认为在同一连通块中。如果不理解的话,请看样例二。
思路:dfs求连通块的个数,给各个连通块打上记号:1,2,3……n。则n就是答案。具体请看代码注释。
#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
//dfs求连通块个数
char s[105][105]; //地图
int bh[105][105]; //记录点(x,y)的记号
int n,m;
int d[8][2]={{-1,0},{-1,-1},{0,-1},{1,-1},{1,0},{1,1},{0,1},{-1,1}};//八个方向
void dfs(int x,int y,int num);
int main()
{
while(~scanf("%d%d",&n,&m)&&n&&m)
{
for(int i=0;i<n;i++)
scanf("%s",&s[i]);
int cnt=0;
memset(bh,0,sizeof(bh));
for(int i=0;i<n;i++)
for(int j=0;j<m;j++)
if(bh[i][j]==0&&s[i][j]=='@')//未被标记过且是满足题意的点 继续dfs求解
dfs(i,j,++cnt);
printf("%d\n",cnt);
}
return 0;
}
void dfs(int x,int y,int num)
{
if(x<0||x>=n||y<0||y>=m) //超出边界
return ;
if(bh[x][y]!=0||s[x][y]!='@')//已经被打上记号了或者不是我们要找的点
return ;
bh[x][y]=num; //打上标记
for(int i=0;i<8;i++) //向八个方向扩展
dfs(x+d[i][0],y+d[i][1],num);//同属于一个连通块 num不用改变
}