HDU 1240 三维bfs(其实是英语阅读理解

http://acm.hdu.edu.cn/showproblem.php?pid=1240

You're in space.
You want to get home.
There are asteroids.
You don't want to hit them.

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets.

A single data set has 5 components:

Start line - A single line, "START N", where 1 <= N <= 10.

Slice list - A series of N slices. Each slice is an N x N matrix representing a horizontal slice through the asteroid field. Each position in the matrix will be one of two values:

'O' - (the letter "oh") Empty space

'X' - (upper-case) Asteroid present

Starting Position - A single line, "A B C", denoting the <A,B,C> coordinates of your craft's starting position. The coordinate values will be integers separated by individual spaces.

Target Position - A single line, "D E F", denoting the <D,E,F> coordinates of your target's position. The coordinate values will be integers separated by individual spaces.

End line - A single line, "END"

The origin of the coordinate system is <0,0,0>. Therefore, each component of each coordinate vector will be an integer between 0 and N-1, inclusive.

The first coordinate in a set indicates the column. Left column = 0.

The second coordinate in a set indicates the row. Top row = 0.

The third coordinate in a set indicates the slice. First slice = 0.

Both the Starting Position and the Target Position will be in empty space.
 

Output

For each data set, there will be exactly one output set, and there will be no blank lines separating output sets.

A single output set consists of a single line. If a route exists, the line will be in the format "X Y", where X is the same as N from the corresponding input data set and Y is the least number of moves necessary to get your ship from the starting position to the target position. If there is no route from the starting position to the target position, the line will be "NO ROUTE" instead.

A move can only be in one of the six basic directions: up, down, left, right, forward, back. Phrased more precisely, a move will either increment or decrement a single component of your current position vector by 1.
 

Sample Input

START 1
O
0 0 0
0 0 0
END
START 3
XXX
XXX
XXX
OOO
OOO
OOO
XXX
XXX
XXX
0 0 1
2 2 1
END
START 5
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
XXXXX
XXXXX
XXXXX
XXXXX
XXXXX
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
OOOOO
0 0 0
4 4 4
END

Sample Output

1 0
3 4
NO ROUTE

题目大意:如标题所示,自然是三维空间的。START N,说明这个空间的大小是N*N*N的,然后依次输入的第一层第一行第一列、……第一层第一行第N列、第一层第二行第一列……第一层第N行第N列、第二层第一行第一列……。已经写得很清楚了,不明白的自己看一下样例二。

思路:这tm就是一个bfs的水题,二维大家都会做,这个三维的也很简单,只有六个方向。(三条直线嘛)障碍物什么的也不用说了。难就难在,你能看懂题意不,对我这英语弱渣极度不友好!谴责!

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
typedef long long ll;
typedef unsigned long long ull;
using namespace std;
				//三维bfs
int d[6][3]={{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
char s[12][12][12];
int bx,by,bz;
int ex,ey,ez;
int n;

struct node
{
	int x,y,z,step;
	node ()
	{}
	node(int X,int Y,int Z,int S)
	{
		x=X,y=Y,z=Z,step=S;
	}
};

void bfs();

int main()
{
	string str;
	while(cin>>str)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				for(int k=0;k<n;k++)
					cin>>s[j][k][i];
		cin>>bx>>by>>bz;
		cin>>ex>>ey>>ez;
		cin>>str;
		bfs();
	}
	return 0;
}

void bfs()
{
	s[bx][by][bz]=='X';
	node a;
	a.x=bx,a.y=by,a.z=bz,a.step=0;
	queue<node> q;
	q.push(a);
	while(!q.empty())
	{
		node b=q.front();
		q.pop();
		if(b.x==ex&&b.y==ey&&b.z==ez)
		{
			printf("%d %d\n",n,b.step);
			return ;
		}
		for(int i=0;i<6;i++)
		{
			int dx=b.x+d[i][0];
			int dy=b.y+d[i][1];
			int dz=b.z+d[i][2];
			if(dx<0||dx>=n||dy<0||dy>=n||dz<0||dz>=n||s[dx][dy][dz]=='X')
				continue;
			node c(dx,dy,dz,b.step+1);
			q.push(c);
			s[dx][dy][dz]='X';
		}
	}
	printf("NO ROUTE\n");
	return ;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值