HDU 6441 费马大定理+本原勾股数

http://acm.hdu.edu.cn/showproblem.php?pid=6441

people in USSS love math very much, and there is a famous math problem .

give you two integers n ,a ,you are required to find 2 integers b ,c such that an +bn=cn .

Input

one line contains one integer T ;(1≤T≤1000000)(1≤T≤1000000)

next T lines contains two integers nn ,aa ;(0≤n≤1000,000000 ,000,3≤a≤40000)

Output

print two integers b ,c if b ,c exits;(1≤b,c≤1000(1≤b,c≤1000 ,000000 ,000)000) ;

else print two integers -1 -1 instead.

Sample Input

1
2 3

Sample Output

4 5

题目大意:给出n和a,若方程a^n+b^n=c^n有解,输出b和c的值,否则输出-1 -1。

思路:费马大定理:

还有以下三种情况:(1)当n=0时,无解。(2)当n=1时,任意输出就好了,比如a+a=2*a等等。(3)当n=2时,这时候要用到本原勾股数的知识。可分a为奇数和偶数进行讨论,比如a为奇数时,a^2也为奇数,可取b=(a^2-1)/2,c=(a^2+1)/2;当a为偶数时,即a=2*n时,可取b=n^2-1,c=n^2+1。(a>=4)

#include<iostream>
#include<cstdio>
#include<stack>
#include<cmath>
#include<cstring>
#include<queue>
#include<map>
#include<set>
#include<algorithm>
#include<iterator>
#define INF 0x3f3f3f3f
#define EPS 1e-10
typedef long long ll;
typedef unsigned long long ull;
using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,a;
		scanf("%d%d",&n,&a);
		if(n>=3||n==0)
			printf("-1 -1\n");
		else if(n==2)
		{
			if(a&1)
			{
				int temp=(a-1)/2;
				printf("%d %d\n",2*temp*temp+2*temp,2*temp*temp+2*temp+1);
			}
			else
			{
				int temp=a/2-1;
				printf("%d %d\n",temp*temp+2*temp,temp*temp+2*temp+2);
			}
		}
		else if(n==1)
			printf("%d %d\n",a,2*a);
	}
	return 0;
}

 

      

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值