POJ 2255 二叉树遍历

http://poj.org/problem?id=2255

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.
This is an example of one of her creations:

                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!

Input

The input will contain one or more test cases.
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)
Input is terminated by end of file.
 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

题目大意: 给出先序遍历和中序遍历, 让你输出后序遍历。

思路: 首先清楚三种便利方式,先序遍历(PreOrder): 根左右;中序遍历(InOrder): 左根右; 后序遍历(PostOrder): 左右根。 根据先序遍历和中序遍历我们可以这样考虑, 先序遍历的第一个必定是根结点, 我们在中序遍历中找到根结点的位置, 然后就知道了左子树结点的个数和右子树结点的个数, 这样就就可以递归的处理下去了。 根据后续遍历的规则:先遍历左子树, 再遍历右子树, 最后输出根结点的值,就可以解决这道题了。

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<cmath>
using namespace std;

char preorder[40];
char inorder[40];

void dfs(int l1,int r1,int l2,int r2);//标记先序 中序的起始位置和终点位置

int main()
{
    while(~scanf("%s%s",preorder,inorder))
    {
        int len=strlen(preorder);
        dfs(0,len-1,0,len-1);
        printf("\n");
    }
    return 0;
}

void dfs(int l1,int r1,int l2,int r2)   //后序遍历
{
    if(l1>r1||l2>r2)
        return ;
    int p=l2;
    while(inorder[p]!=preorder[l1]) //找根结点的位置
        p++;
    int temp=r2-p;   //右子树节点个数
    dfs(l1+1,r1-temp,l2,r2-temp-1); //dfs左子树
    dfs(r1-temp+1,r1,p+1,r2);//dfs右子树
    printf("%c",inorder[p]);    //输出根结点值
    return ;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值