POJ 1423 数学对数运算

http://poj.org/problem?id=1423

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line.

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input

2
10
20

Sample Output

7
19

题目大意:共T组数据,每组数据给出m,求m!有多少位。

思路:我们都知道[10^(n-1),10^n-1]有n位,设F(n)等于n的位数,那么F(n)=log10(n)+1。(向下取整)那么F(m!)=log10(m!)+1,根据对数运算,我们可得到:F(m!)=log10(1)+log10(2)+……+log10(m)+1,那么这道题就解决了,直接预处理出10^7以内的结果存到数组中就行了。(不然可能会TLE 因为有T数据)

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<queue>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

int a[10000005];//代表位数

int main()
{
    double sum=log10(1);
    a[1]=1;
    for(int i=2;i<=10000000;i++)
    {
        sum+=log10(i);
        a[i]=sum+1;//int型会向下取整
    }
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m;
        scanf("%d",&m);
        printf("%d\n",a[m]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值