poj3744之矩阵快速幂+概率DP

Scout YYF I
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4410 Accepted: 1151

Description

YYF is a couragous scout. Now he is on a dangerous mission which is to penetrate into the enemy's base. After overcoming a series difficulties, YYF is now at the start of enemy's famous "mine road". This is a very long road, on which there are numbers of mines. At first, YYF is at step one. For each step after that, YYF will walk one step with a probability of  p, or jump two step with a probality of 1- p. Here is the task, given the place of each mine, please calculate the probality that YYF can go through the "mine road" safely.

Input

The input contains many test cases ended with  EOF.
Each test case contains two lines.
The First line of each test case is  N (1 ≤  N ≤ 10) and  p (0.25 ≤  p ≤ 0.75) seperated by a single blank, standing for the number of mines and the probability to walk one step.
The Second line of each test case is N integer standing for the place of N mines. Each integer is in the range of [1, 100000000].

Output

For each test case, output the probabilty in a single line with the precision to 7 digits after the decimal point.

Sample Input

1 0.5
2
2 0.5
2 4

Sample Output

0.5000000
0.2500000
/*分析:对于n个地雷s[1],s[2],s[3],s[4]...s[n]
假设s都是不递减的。
假设dp[i]表示从1到达i这个位置的概率
则:
dp[s[1]-1]为1~s[1]-1的概率//s[1]不能到达
dp[s[2]-1]为1~s[2]-1也是1->s[1]-1->s[1]+1->s[2]-1的概率
由于最多只能跳两格
所以dp[s[i]+1]一定是从dp[s[i]-1]到达
然后从dp[s[i]+1]到达dp[s[i+1]-1];//这部分就可以用矩阵快速幂
另外根据公式dp[i]=p*dp[i-1]+(1-p)*dp[i-2]也可知从s[i]+1 => s[i+1]-1用矩阵快速幂求
构造初始矩阵:
p 1-p   *  dp[i]      =  dp[i+1]
1 0        dp[i-1]        dp[i]
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=10+10;
const int N=2;
int n,s[MAX];
double array[N][N],sum[N][N],p;

void InitMatrix(){
	array[0][0]=p;
	array[0][1]=1-p;
	array[1][0]=1;
	array[1][1]=0;
	for(int i=0;i<N;++i){
		for(int j=0;j<N;++j)sum[i][j]=(i == j);
	}
}

void MatrixMult(double a[N][N],double b[N][N]){
	double c[N][N]={0};
	for(int i=0;i<N;++i){
		for(int j=0;j<N;++j){
			for(int k=0;k<N;++k){
				c[i][j]+=a[i][k]*b[k][j];
			}
		}
	}
	for(int i=0;i<N;++i)for(int j=0;j<N;++j)a[i][j]=c[i][j];
}

double Matrix(int k){
	if(k<0)return 0;//表示s[i-1]~s[i]之间无位置 
	InitMatrix();//初始化矩阵
	while(k){//有k+1个位置,到达第k+1个位置所以是k次 
		if(k&1)MatrixMult(sum,array);
		MatrixMult(array,array);
		k>>=1; 
	}
	return sum[0][0];//sum[0][0]*dp[1]+sum[0][1]*dp[0]
}

int main(){
	while(~scanf("%d%lf",&n,&p)){
		for(int i=1;i<=n;++i)scanf("%d",&s[i]);
		sort(s+1,s+1+n);
		double ans=Matrix(s[1]-2);//1~s[1]-1的概率 
		for(int i=2;i<=n;++i){
			if(s[i] == s[i-1])continue;
			double temp=Matrix(s[i]-s[i-1]-2);//s[i-1]~s[i]之间有s[i]-s[i-1]-1个位置,需要走s[i]-s[i-1]-2次到达最后一个位置
			ans=ans*(1-p)*temp;//从s[i-1]-1的位置跳两格到s[i-1]+1再到s[i]-1 
		}
		printf("%.7f\n",ans*(1-p));//在s[n]-1位置还需要跳两格才安全了 
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值