poj2282

The Counting Problem
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 2991 Accepted: 1592

Description

Given two integers a and b, we write the numbers between a and b, inclusive, in a list. Your task is to calculate the number of occurrences of each digit. For example, if a = 1024 and b = 1032, the list will be 
1024 1025 1026 1027 1028 1029 1030 1031 1032

there are ten 0's in the list, ten 1's, seven 2's, three 3's, and etc.

Input

The input consists of up to 500 lines. Each line contains two numbers a and b where 0 < a, b < 100000000. The input is terminated by a line `0 0', which is not considered as part of the input.

Output

For each pair of input, output a line containing ten numbers separated by single spaces. The first number is the number of occurrences of the digit 0, the second is the number of occurrences of the digit 1, etc.

Sample Input

1 10
44 497
346 542
1199 1748
1496 1403
1004 503
1714 190
1317 854
1976 494
1001 1960
0 0

Sample Output

1 2 1 1 1 1 1 1 1 1
85 185 185 185 190 96 96 96 95 93
40 40 40 93 136 82 40 40 40 40
115 666 215 215 214 205 205 154 105 106
16 113 19 20 114 20 20 19 19 16
107 105 100 101 101 197 200 200 200 200
413 1133 503 503 503 502 502 417 402 412
196 512 186 104 87 93 97 97 142 196
398 1375 398 398 405 499 499 495 488 471
294 1256 296 296 296 296 287 286 286 247

Source


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<cmath>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10+5;
int a[MAX],b[MAX];

void copy(int* a,int* b){
	for(int i=0;i<10;++i){
		a[i]=b[i],b[i]=0;
	}
}

int calculate(int n,int m){
	int x=n/10,y=n%10,temp=x;
	for(int i=0;i<=y;++i)b[i]+=m;
	for(int i=0;i<10;++i)b[i]+=m*x;
	b[0]-=m;//减掉左边是0的情况
	while(temp)b[temp%10]+=m*(y+1),temp=temp/10; 
	if(x)calculate(x-1,m*10);
}

int main(){
	int A,B;
	while(cin>>A>>B,A+B){
		if(A>B)swap(A,B);
		memset(b,0,sizeof b);
		calculate(A-1,1);
		copy(a,b);
		calculate(B,1);
		for(int i=0;i<9;++i)printf("%d ",b[i]-a[i]);
		printf("%d\n",b[9]-a[9]);
	}
	return 0;
}

哪位大神路过求教下下面我用的另一种方法怎么求出0的个数,1~9我都能求出来,但是0的个数会出错,想了好久总是出错

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=19+3;
__int64 dp[MAX][3];
/*
dp[i][0]表示长度<=i的不含有0/1/2/3.../9的数的个数
dp[i][1]表示长度<=i的含有0/1/2/3.../9的数的个数
dp[i][2]表示长度<=i的数中总共含有0/1/2/3.../9的个数 
*/ 
int digit[MAX];

void init(){
	dp[0][0]=1;dp[1][0]=9;dp[1][1]=1;dp[1][2]=1;
	for(int i=2;i<MAX;++i){
		dp[i][0]=dp[i-1][0]*9; 
		dp[i][1]=dp[i-1][1]*10+dp[i-1][0];
		dp[i][2]=dp[i-1][2]*10+dp[i-1][1]+dp[i-1][0];                                                                                               
	}
}

__int64 digit_dp(__int64 n,int m){
	int size=0;
	__int64 sum=0,last=0;
	while(n)digit[++size]=n%10,n=n/10;
	for(int i=size;i>=1;--i){
		sum+=dp[i-1][2]*digit[i]+last*(digit[i]*(dp[i-1][0]+dp[i-1][1]));
		if(digit[i] == m)++last;
		if(digit[i]>m)sum+=dp[i-1][1]+dp[i-1][0];
	} 
	return sum+last;
}

int main(){
	init();
	__int64 a,b;
	while(scanf("%I64d%I64d",&a,&b)!=EOF){
		if(a>b)a=a+b,b=a-b,a=a-b;
		for(int i=0;i<9;++i)printf("%d ",digit_dp(b,i)-digit_dp(a-1,i));
		printf("%I64d\n",digit_dp(b,9)-digit_dp(a-1,9));
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值