Can you find it?
Time Limit: 10000/3000 MS (Java/Others) Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 7803 Accepted Submission(s): 2027
Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
Sample Input
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
Sample Output
Case 1: NO YES NO
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<iomanip>
#define INF 99999999
using namespace std;
const int MAX=500+10;
__int64 a[MAX],b[MAX],c[MAX];
__int64 s[MAX*MAX];
bool search(__int64 x,int n){
int left=0,right=n-1;
while(left<=right){
int mid=left+right>>1;
if(s[mid] == x)return true;
else if(s[mid]<x)left=mid+1;
else right=mid-1;
}
return false;
}
int main(){
int A,B,C,n,num=0;
__int64 m;
while(cin>>A>>B>>C){
for(int i=0;i<A;++i)cin>>a[i];
for(int i=0;i<B;++i)cin>>b[i];
for(int i=0;i<C;++i)cin>>c[i];
for(int i=0;i<A;++i){
for(int j=0;j<B;++j)s[i*B+j]=a[i]+b[j];
}
sort(s,s+A*B);
cin>>n;
int i;
cout<<"Case "<<++num<<':'<<endl;
while(n--){
cin>>m;
for(i=0;i<C;++i){
if(search(m-c[i],A*B)){cout<<"YES"<<endl;break;}
}
if(i == C)cout<<"NO"<<endl;
}
}
return 0;
}