hdu2289

Cup

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2622    Accepted Submission(s): 833


Problem Description
The WHU ACM Team has a big cup, with which every member drinks water. Now, we know the volume of the water in the cup, can you tell us it height? 

The radius of the cup's top and bottom circle is known, the cup's height is also known.
 

Input
The input consists of several test cases. The first line of input contains an integer T, indicating the num of test cases.
Each test case is on a single line, and it consists of four floating point numbers: r, R, H, V, representing the bottom radius, the top radius, the height and the volume of the hot water.

Technical Specification

1. T ≤ 20.
2. 1 ≤ r, R, H ≤ 100; 0 ≤ V ≤ 1000,000,000.
3. r ≤ R.
4. r, R, H, V are separated by ONE whitespace.
5. There is NO empty line between two neighboring cases.

 

Output
For each test case, output the height of hot water on a single line. Please round it to six fractional digits.
 

Sample Input
  
  
1 100 100 100 3141562
 

Sample Output
  
  
99.999024
 
这题可以二分求,也可以直接补全圆锥然后用比例求出
用比例求出:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<math.h>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10;
const double PI=acos(-1.0);

int main(){
	int t;
	double r,R,H,V,h;
	cin>>t;
	while(t--){
		cin>>r>>R>>H>>V;
		if(r == R){//圆柱体,直接求高 
			h=V/PI/r/r;
		}else{//圆台,补全为圆锥求按比例求高 
			h=r*H/(R-r);//补全的那部分圆锥高
			double v=PI*r*r*h/3;//补全那部分圆锥的体积
			h=pow((v+V)/v,1.0/3)*h-h;//有水那部分高 
		}
		if(h>H)h=H;
		cout<<fixed<<setprecision(6)<<h<<endl;
	}
	return 0;
}

二分求出:
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<queue>
#include<algorithm>
#include<map>
#include<math.h>
#include<iomanip>
#define INF 99999999
using namespace std;

const int MAX=10;
const double PI=acos(-1.0);
const double eps=1e-7;
double r,R,H,V;

double volume(double h){//计算圆台的体积
	double Ro=(r*H-r*h+R*h)/H;//用梯形面积求半径,不用圆锥高之比求半径是因为r可能等于R 
	return PI*h*(r*r+Ro*Ro+Ro*r)/3;//求圆台面积 
}

double search(double &key,double &h){
	double left=0,right=h;
	while(right-left>eps){
		double mid=(left+right)/2;
		double v=volume(mid);
		if(fabs(v-key)<eps)return mid;
		else if(v<key)left=mid;
		else right=mid;
	}
	return right;//水的体积超过整个杯子的体积则高为H 
}

int main(){
	int t;
	cin>>t;
	while(t--){
		cin>>r>>R>>H>>V;
		double h=search(V,H);
		cout<<fixed<<setprecision(6)<<h<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值