hdu 1042 N!

1042 N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 65375    Accepted Submission(s): 18705


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
      
      
1 2 3
 

Sample Output
      
      
1 2 6




高精度阶乘

/*模拟手工乘法运算,相当于高精度乘单精度,虽然方法通俗易懂,但所花时间较长,大约3300MS*/

代码如下


#include<iostream>
#include<cstring>
#define maxn 50000
using namespace std;
int n;
int a[maxn];
void fact()
{
	memset(a,0,sizeof(a));
	a[0]=1;
	for(int i=2;i<=n;i++)
	{
		int w=0;
		for(int j=0;j<maxn;j++)
		{
			a[j]=a[j]*i+w;
			w=a[j]/10;
			a[j]%=10;
		}
	}
	int max=maxn;
	while(!a[max-1]) max--;
	for(int i=max-1;i>=0;i--) cout<<a[i];
	cout<<endl;
}
int main()
{
	while(cin>>n)
	{
		fact();
	} 
 } 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值