CD Making

Tom has NN songs and he would like to record them into CDs. A single CD can contain at most KK songs. In addition, Tom is very superstitious and he believes the number 13 would bring bad luck, so he will never let a CD contain exactly 1313 songs. Tom wants to use as few CDs as possible to record all these songs. Please help him.

Input
There are TT test cases. The first line gives TT, number of test cases. TT lines follow, each contains NN and KK, number of songs Tom wants to record into CDs, and the maximum number of songs a single CD can contain.

1≤N≤1000,1≤K≤10001≤N≤1000,1≤K≤1000
Output
For each test case, output the minimum number of CDs required, if the above constraints are satisfied.

Sample Input
2
5 2
13 13
Sample Output
3
2
Hint
If Tom has 55 songs to record and a single CD can contain up to 22 songs, Tom has to use 33 CDs at minimum, each contains 22, 22, 11 songs, respectively.

In the second case, Tom wants to record 1313 songs, and a single CD can hold 1313 songs at most. He would have been able to use only 11 CD if he were not so superstitious. However, since he will not record exactly 1313 songs into a single CD, he has to use 22 CDs at least, the first contains 1212 songs and the second contains one(Other solutions to achieve 22 CDs are possible, such as (1111, 22), (1010, 33), etc.).

#include <cstdio>
int main(){
    int t;
    scanf("%d",&t);
    while (t--){
        int n,k;
        scanf("%d%d",&n,&k);
        int ans = 0;
        int sum = 0;
        int temp = n;
        if (k == 13) {
            ans = n/12;
            if (n%12) ans+=1;
        }else if(k!=14){
            ans = n/k;
            if (n%k) ans++;
            if (n == 13 && n < k) ans++;
        }else if (k == 14){
            ans = n/k;
            if (n%k) ans++;
            if (n%k==13) ans++;
        }

        printf("%d\n",ans);
    }
    return 0;
}

这个情况考虑的有点多啊。。。。QAQ

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值