hdu1081

To The Max

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5749    Accepted Submission(s): 2715


Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 

Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 

Output
Output the sum of the maximal sub-rectangle.
 

Sample Input
  
  
4 0 -2 -7 0 9 2 -6 2 -4 1 -4 1 -1 8 0 -2
 

Sample Output
  
  
15


题意:求最大子矩阵和。其实跟1003差不多,就是把维数加到了二维,只要压缩一下变成一维就可以了。把列之和压缩到最后一行的元素里面,通过做差就可以o(1)得到一列里面的某个子列的和了。把这一个子列看成一个元素,用一维做法解决。

#include<algorithm>
#include <cstring>
#include<cstdio>
#include<stdlib.h>
#define INF 0x7ffffff
using namespace std;

int dp[101];
int sum[101][101];
int main()
{
     int n, number;
    while(~scanf("%d",&n))
    {
        memset(sum,0,sizeof(sum));
        for(int i = 1; i <= n; i ++)
            for(int j = 1; j <= n; j ++)
            {
                scanf("%d",&number);
                sum[j][i] = sum[j - 1][i] + number;
            }

        int ans = -INF;
        for(int i = 1; i <= n; i ++) 	  //第i行
            for(int j = i; j <= n; j ++) //到第j行确定一个元素矩阵区间
                for(int k = 1; k <= n; k ++) //一维方法求以第k个元素为结尾的最大子段和;
                {
                    dp[k] = sum[j][k] - sum[i - 1][k];
                    dp[k] = max(dp[k],dp[k] + dp[k - 1]);
                    ans = max(dp[k],ans);//保留答案
                }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值