字符变成下一子母



1062: 字母变成其下一字母

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 5590   Solved: 1867
[ Submit][ Status][ Web Board]

Description

输入一行电报文字,将字母变成其下一字母(如’a’变成’b’……’z’变成’a’其它字符不变)。

Input

一行字符

Output

加密处理后的字符

Sample Input

a b

Sample Output

b c

HINT

/*
#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>//定义杂项函数及内存分配函数

using namespace std;

int main()
{
    char a[10];
    int i,len;
    gets(a);

    len=strlen(a);

    for(i=0;i<len;i++)
    {
        a[i]=a[i]+1;
    }

    puts(a);


    return 0;
}
*/

#include<stdio.h>
int main()
{
	char a;
	while(scanf("%c",&a)!=EOF)//判断是否读到结尾
	{
		if(a=='z')
			a='a';
		else if(a>='a'&&a<'z')
			a=a+1;
	printf("%c",a);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值