Olympiad
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 510 Accepted Submission(s): 370
Problem Description
You are one of the competitors of the Olympiad in numbers. The problem of this year relates to beatiful numbers. One integer is called beautiful if and only if all of its digitals are different (i.e. 12345 is beautiful, 11 is not beautiful and 100 is not beautiful). Every time you are asked to count how many beautiful numbers there are in the interval
[a,b] (a≤b)
. Please be fast to get the gold medal!
Input
The first line of the input is a single integer
T (T≤1000)
, indicating the number of testcases.
For each test case, there are two numbers a and b , as described in the statement. It is guaranteed that 1≤a≤b≤100000 .
For each test case, there are two numbers a and b , as described in the statement. It is guaranteed that 1≤a≤b≤100000 .
Output
For each testcase, print one line indicating the answer.
Sample Input
2 1 10 1 1000
Sample Output
10 738
Author
XJZX
Source
使用打表法
代码如下:
#include <iostream>
#include <set>
#include <cstring>
using namespace std;
int cnt[100001];
void CNT()
{
int count,sum=0,c;
set<int> s;
memset(cnt,0,sizeof(cnt));
for(int i=1;i<=100000;i++)
{
count=0;
c=i;
while(c!=0)
{
s.insert(c%10);
c=c/10;
count++;
}
if(s.size()==count)sum++;
cnt[i]=sum;
s.clear();
}
}
int main()
{
int T,a,b,count;
CNT();
cin>>T;
while(T--)
{
cin>>a>>b;
cout<<cnt[b]-cnt[a-1]<<endl;
}
return 0;
}
#include <set>
#include <cstring>
using namespace std;
int cnt[100001];
void CNT()
{
int count,sum=0,c;
set<int> s;
memset(cnt,0,sizeof(cnt));
for(int i=1;i<=100000;i++)
{
count=0;
c=i;
while(c!=0)
{
s.insert(c%10);
c=c/10;
count++;
}
if(s.size()==count)sum++;
cnt[i]=sum;
s.clear();
}
}
int main()
{
int T,a,b,count;
CNT();
cin>>T;
while(T--)
{
cin>>a>>b;
cout<<cnt[b]-cnt[a-1]<<endl;
}
return 0;
}