HDU5908 Abelian Period

Abelian Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)
Total Submission(s): 622    Accepted Submission(s): 263


Problem Description
Let S be a number string, and occ(S,x) means the times that number x occurs in S .

i.e. S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1 .

String u,w are matched if for each number i , occ(u,i)=occ(w,i) always holds.

i.e. (1,2,2,1,3)(1,3,2,1,2) .

Let S be a string. An integer k is a full Abelian period of S if S can be partitioned into several continous substrings of length k , and all of these substrings are matched with each other.

Now given a string S , please find all of the numbers k that k is a full Abelian period of S .
 

Input
The first line of the input contains an integer T(1T10) , denoting the number of test cases.

In each test case, the first line of the input contains an integer n(n100000) , denoting the length of the string.

The second line of the input contains n integers S1,S2,S3,...,Sn(1Sin) , denoting the elements of the string.
 

Output
For each test case, print a line with several integers, denoting all of the number k . You should print them in increasing order.
 

Sample Input
  
  
2 6 5 4 4 4 5 4 8 6 5 6 5 6 5 5 6
 

Sample Output
  
  
3 6 2 4 8
 

Source

BestCoder Round #88 

http://acm.split.hdu.edu.cn/showproblem.php?pid=5908

//判断因子就OK了

#include<stdio.h>
#include<string.h>
#include<set>
using namespace std;
int main()
{
    int a[100010],b[100010],c[100010];
    int t,i,j,k,h,n,flag,check;
    scanf("%d",&t);
    multiset<int>s1;
    multiset<int>s2;
    multiset<int>::iterator it1,it2;
    while(t--)
    {
        scanf("%d",&n);
        memset(c,0,sizeof(c));
        s1.clear();
        s2.clear();
        k=0;
        for(i=1; i<=n; i++)
        {
            if(n%i==0)
                b[k++]=i;   //求出因子
        }
        flag=1;
        for(i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(a[i]!=a[0])
                flag=0;
        }
        if(flag)
        {
            for(i=0; i<k; i++)
                if(i==k-1)  printf("%d\n",b[i]);
                else   printf("%d ",b[i]);
            continue;
        }
        int       cnt=0;
        for(i=1; i<k; i++)
        {
            if(c[b[i]]) continue;
            check=0;
            s1.clear();
            for(h=0; h<b[i]; h++)
                s1.insert(a[h]);
            for(j=0; j<n;)
            {
                s2.clear();
                for(h=0; h<b[i]; h++)
                    s2.insert(a[j++]);
   for(it1=s1.begin(),it2=s2.begin(); it1!=s1.end(); it1++,it2++)//判断匹配吗
                    if((*it1)!=(*it2))
                    {
                        check=1;
                        break;
                    }
                if(check) break;
            }
            if(!check)
            {
                for(h=i; h<k; h++)
                    if(b[h]%b[i]==0)//它的倍数肯定也成立
                    {
                        c[b[h]]=1;
                        cnt++;
                    }
            }
        }
        for(i=1,j=0; j<cnt; i++)
            if(c[b[i]])
            {
                if(j==cnt-1)
                    printf("%d\n",b[i]);
                else printf("%d ",b[i]);
                j++;
            }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值