HDU5908Abelian Period

Abelian Period

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/131072 K (Java/Others)


Problem Description
Let  S  be a number string, and  occ(S,x)  means the times that number  x  occurs in  S .

i.e.  S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1 .

String  u,w  are matched if for each number  i occ(u,i)=occ(w,i)  always holds.

i.e.  (1,2,2,1,3)(1,3,2,1,2) .

Let  S  be a string. An integer  k  is a full Abelian period of  S  if  S  can be partitioned into several continous substrings of length  k , and all of these substrings are matched with each other.

Now given a string  S , please find all of the numbers  k  that  k  is a full Abelian period of  S .
 

Input
The first line of the input contains an integer  T(1T10) , denoting the number of test cases.

In each test case, the first line of the input contains an integer  n(n100000) , denoting the length of the string.

The second line of the input contains  n  integers  S1,S2,S3,...,Sn(1Sin) , denoting the elements of the string.
 

Output
For each test case, print a line with several integers, denoting all of the number  k . You should print them in increasing order.
 

Sample Input
  
  
2 6 5 4 4 4 5 4 8 6 5 6 5 6 5 5 6
 

Sample Output
  
  
3 6 2 4 8
题意:给一个数字串,长度为n,里面每个数字1Sin,如果将这个串分成多部分,每部分是连续的k个元素,

且这些部分中每个数字出现的次数相同。输出所有这样的k值

解析:本题可以用暴力来解。分析可得k必须是n的因子,又n<10^5,n的因子数不会超过126个(写了个程序试了一下),

所以可以使用枚举k的方法,然后用O(n)的时间检查k是否满足条件。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
using namespace std;
#define N 100005
int cnt1[N], cnt2[N];
int a[N], n;
bool ok[N];
int check(int i){
    memset(cnt1, 0, sizeof(cnt1));
    memset(cnt2, 0, sizeof(cnt2));
    for(int j = 1; j <= i; j++){
        cnt1[a[j]]++;
    }
    for(int j = 2; j <= n / i; j++){
        int l = i*(j-1)+1;
        int r = i * j;
        for(int k = l; k <= r; k++){
            cnt2[a[k]]++;
            if(cnt2[a[k]] > cnt1[a[k]])
                return 0;
        }
        for(int k = l; k <= r; k++)
            cnt2[a[k]]--;
    }
    return 1;
}
int main(){
    int t, x, ans;
    
    cin>>t;
    while(t--){
        cin>>n;
        memset(ok, false, sizeof(ok));
        for(int i = 1; i <= n; i++)
            scanf("%d", &a[i]);
        
        for(int i = 1; i <= (n>>1); i++){
            if(n % i==0 && check(i))
                printf("%d ", i);
        }
        cout<<n<<endl;
    }
    return 0;
}
开始没想到用暴力,因为n数字太大,感觉会超时。然后看网上大神们有用暴力解的,于是写了个程序测试了一下1~10w

这些数字的因子数,我测的是因子最多126个。而且大部分数的因子不会超过100个,这样看的话,枚举k也是有可能的。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值