BNU17818 UVA679 Dropping Balls

Dropping Balls

Time Limit: 3000ms
Memory Limit: 131072KB
This problem will be judged on  UVA. Original ID:  679
64-bit integer IO format:  %lld      Java class name:  Main
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • [PDF Link]


      Dropping Balls 

    A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball's moving direction a flag is set up in every non-terminal node with two values, either false ortrue. Initially, all of the flags are false. When visiting a non-terminal node if the flag's current value at this node is false, then the ball will first switch this flag's value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag's value, i.e., from thetrue to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.


    For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag's values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag's values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag's values at node 1, node 2, and node 5 before it stops at position 10.


    Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.


    Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of Iwill not exceed the total number of leaf nodes for the given FBT.

    Please write a program to determine the stop position P for each test case.


    For each test cases the range of two parameters D and I is as below: 

    \begin{displaymath}2 \le D \le 20, \mbox{ and } 1 \le I \le 524288.\end{displaymath}

    Input 

    Contains  l+2 lines.
    
    Line 1 		 I the number of test cases 
    Line 2 		 $D_1 \ I_1$
    test case #1, two decimal numbers that are separatedby one blank 
    ... 		 		 
    Line k+1 $D_k \ I_k$
    test case #k 
    Line l+1 $D_l \ I_l$
    test case #l 
    Line l+2 -1 		 a constant -1 representing the end of the input file
    

    Output 

    Contains  l lines.
    
    Line 1 		 the stop position P for the test case #1 
    ... 		 
    Line k the stop position P for the test case #k 
    ... 		 
    Line l the stop position P for the test case #l
    

    Sample Input 

    5
    4 2
    3 4
    10 1
    2 2
    8 128
    -1
    

    Sample Output 

    12
    7
    512
    3
    255
    https://www.bnuoj.com/v3/problem_show.php?pid=17818

    给一个满二叉树 深度为D,在结点1处放一个球,它会下;落.每个结点都有一个开关,初始时全部关闭,每当有一个小球下落时,状态都会改变.

    开关关往左走,否则右走,直到走到叶子结点.问第I个小球最终到哪个叶子结点.

    暴力还是不行吧得开个大数组记录状态1百万 1000组数据每次初始化超时

    找规律吧. 

    #include<stdio.h>
    int h;
    int  POW()
    {
        int p=1;
        while(h--)
            p*=2;
        return p;
    }
    
    int main()
    {
        int  t,n,d,k;
        while(~scanf("%d",&t))
        {   if(t==-1) break;
            while(t--)
            {   k=1;
                scanf("%d%d",&h,&n);
                  int gg=POW()-1;
                for(;;)
                {
                    if(n%2==0)
                    {
                        d=k;
                        k=k*2+1;
                        n=n/2;
                    }
                    else
                    {
                        d=k;
                        k*=2;
                        n=n-n/2;
                    }
                    if(k>gg)//if(k>POW()-1)小心错了 h为全局变量
                    {                //  因为每进行一次h就变了
                        printf("%d\n",d);
                        break;
                    }
                }
            }
        }
        return 0;
    }
    

    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值