BNU17268 UVA129 Krypton Factor

Krypton Factor

Time Limit: 3000ms
Memory Limit: 131072KB
This problem will be judged on  UVA. Original ID:  129
64-bit integer IO format:  %lld      Java class name:  Main
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • [PDF Link]


     Krypton Factor 

    You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called ``easy''. Other sequences will be called ``hard''.

    For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

    • BB
    • ABCDACABCAB
    • ABCDABCD

    Some examples of hard sequences are:

    • D
    • DC
    • ABDAB
    • CBABCBA

    Input and Output

    In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

    For example, with L = 3, the first 7 hard sequences are:

     A 
    AB 
    ABA 
    ABAC 
    ABACA 
    ABACAB 
    ABACABA

    As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

    Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

    ABAC ABA
    7

    Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

    Sample Input

    30 3
    0 0

    Sample Output

    ABAC ABCA CBAB CABA CABC ACBA CABA
    28

    https://www.bnuoj.com/v3/problem_show.php?pid=17268

    如果一个字符串包含两个相邻的重复字串,则称它是容易的串,其他的串为困难的串

    输出由前L个字符组成的,字典序第N小的困难的串.

    输出的答案保证不超过80个字符

    dfs(但要合理的暴力)

    #include<bits/stdc++.h>
    using namespace std;
    string hh,gg,str;
    int check,cnt,cur;
    int n,l;
    void dfs(int k)
    {
        if(cnt==n)
        {
            check=1;
            cur=k;
            return ;
        }
        int kk,i,flag,j;
        for(i=0; i<l; i++)
        {
            int ggg=str.length()-1;
            if(k>ggg)//k>str.length()-1;这样写可以吗
                         //已经被坑死详情见
            <a target=_blank href="http://blog.csdn.net/xky140610205/article/details/52947494">http://blog.csdn.net/xky140610205/article/details/52947494</a>
                str+=(i+65);
            else str[k]=i+65;
            flag=0;
            for(j=k-1,kk=1; j>=0; j=j-2,kk++)
            {
                gg=str.substr(j,kk);
                hh=str.substr(j+kk,kk);
                if(gg==hh)
                {
                    flag=1;
                    break;
                }
            }
            if(flag)
                continue;
            cnt++;
            dfs(k+1);
            if(check) return ;
        }
    }
    
    int main()
    {
        int i;
        while(scanf("%d%d",&n,&l)!=EOF)
        {
            if(n+l==0) break;
            check=0;
            cnt=0;
            str="";//清零
            dfs(0);
            for(i=0; i<cur; i++)
            {
                if(i==cur-1)
                {
                    cout<<str[i]<<endl;
                    continue;
                }
                if((1+i)%64==0)
                {
                    cout<<str[i]<<endl;
                    continue;
                }
                if((1+i)%4==0)
                    cout<<str[i]<<" ";
                else cout<<str[i];
            }
            printf("%d\n",cur);
    
        }
        return 0;
    }
    
    
    

    • 0
      点赞
    • 1
      收藏
      觉得还不错? 一键收藏
    • 0
      评论

    “相关推荐”对你有帮助么?

    • 非常没帮助
    • 没帮助
    • 一般
    • 有帮助
    • 非常有帮助
    提交
    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值