HDU5918 Sequence I

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1234    Accepted Submission(s): 469


Problem Description
Mr. Frog has two sequences a1,a2,,an and b1,b2,,bm and a number p. He wants to know the number of positions q such that sequence b1,b2,,bm is exactly the sequence aq,aq+p,aq+2p,,aq+(m1)p where q+(m1)pn and q1 .
 

Input
The first line contains only one integer T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers 1n106,1m106 and 1p106 .

The second line contains n integers a1,a2,,an(1ai109) .

the third line contains m integers b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

Source

2016中国大学生程序设计竞赛(长春)-重现赛  

http://acm.split.hdu.edu.cn/showproblem.php?pid=5918

问第二个字符串在第一个字符串出现的次数(按一定间隔)

本题应该要考的是KMP

记得刘汝佳白书(尽管最坏情况下朴素匹配算法表现不佳,但实际上对于随机数据,它的表现非常好)

这题多次匹配很多数据KMP还不如暴力

#include<bits/stdc++.h>
using namespace std;
const int  maxx=1e6+10;
int  a[maxx],b[maxx];
int main()
{
    int n,m,q,h,t,sum,i,j,k;
    scanf("%d",&t);
    for(h=1; h<=t; h++)
    {
        scanf("%d%d%d",&n,&m,&q);
        for(i=1; i<=n; i++)
            scanf("%d",&a[i]);
        for(i=1; i<=m; i++)
            scanf("%d",&b[i]);
        sum=0;
        for(i=1; i<=n; i++)
        {
            if(((n-i)/q+1)<m) break;
            if(a[i]==b[1])
            {
                k=i;
                for(j=1; j<=m; j++)
                {
                    if(a[k]==b[j])
                        k+=q;
                    else break;
                }
                if(j>m) sum++;
            }
        }
        printf("Case #%d: %d\n",h,sum);
    }
    return 0;
}

KMP匹配每次加上间隔就OK了

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int MAX=1000010;
int n,m;
int a[MAX],b[MAX];
int nextval[MAX];
LL ans;
void get_next(int b[],int m)
{
    int i=0;
    nextval[0]=-1;
    int j=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            ++i;
            ++j;
            nextval[i]=j;
        }
        else
            j=nextval[j];
    }
}
int kmp(int a[],int n,int b[],int m,int nextval[],int pos,int p)
{
    int i=pos;
    int j=0;
    while(i<n)
    {
        if(j==-1||a[i]==b[j])
        {
            i+=p;
            j++;
            if(j==m)
            {
                j=nextval[j];
                ans++;
            }
        }
        else
            j=nextval[j];
    }
}

int main()
{
    int t,i,j;
    int cas=1;
    scanf("%d",&t);
    while(t--)
    {
        int p;
        ans=0;
        scanf("%d%d%d",&n,&m,&p);
        for(i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(j=0; j<m; j++)
            scanf("%d",&b[j]);
        get_next(b,m);
        for(i=0; i<p; i++)
        {
            if(i+(m-1)*p>=n)
                break;
            kmp(a,n,b,m,nextval,i,p);
        }
        printf("Case #%d: %lld\n",cas++,ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值