HDU 5918 KMP

Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3226    Accepted Submission(s): 1181


Problem Description
Mr. Frog has two sequences  a1,a2,,an  and  b1,b2,,bm  and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm  is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p  where  q+(m1)pn  and  q1 .
 

Input
The first line contains only one integer  T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers  1n106,1m106  and  1p106 .

The second line contains n integers  a1,a2,,an(1ai109) .

the third line contains m integers  b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2

Case #2: 1

每次生成间隔为q的序列,再用kmp匹配。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxm = 100005;
int a[maxm], b[maxm], p[maxm], vis[maxm], c[maxm], len, n, m;
void find()
{
	int i, j = -1;
	p[0] = -1;
	for (i = 1;i < m;i++)
	{
		while (j >= 0 && b[j + 1] != b[i]) j = p[j];
		if (b[j + 1] == b[i]) j++;
		p[i] = j;
	}
}
int kmp()
{
	int i, j = -1, ans = 0;
	for (i = 0;i < len;i++)
	{
		while (j >= 0 && b[j + 1] != a[i]) j = p[j];
		if (b[j + 1] == a[i]) j++;
		if (j == m - 1) j = p[j], ans++;
	}
	return ans;
}
int main()
{
	int i, j, k, sum, t, ans, cas = 0;
	scanf("%d", &t);
	while (t--)
	{
		scanf("%d%d%d", &n, &m, &k);
		memset(vis, 0, sizeof(vis));
		for (i = 0;i < n;i++)
			scanf("%d", &c[i]);
		for (i = 0;i < m;i++)
			scanf("%d", &b[i]);
		find();ans = 0;
		for (i = 0;i < n;i++)
		{
			if (!vis[i])
			{
				len = 0;
				for (j = i;j < n;j += k)
					a[len++] = c[j], vis[j] = 1;
				ans += kmp();
				//printf("%d\n", ans);
			}
		}
		printf("Case #%d: %d\n",++cas, ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值