UVA10129 BNU18723(拓扑排序)

Ordering Tasks

Time Limit: 3000ms
Memory Limit: 131072KB
This problem will be judged on  UVA. Original ID:  10305
64-bit integer IO format:  %lld      Java class name:  Main
Type: 
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •  
  •                   
  • [PDF Link]

    Problem F

    Ordering Tasks

    Input: standard input

    Output: standard output

    Time Limit: 1 second

    Memory Limit: 32 MB

     

    John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.

    Input

    The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and mn is the number of tasks (numbered from1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.

    Output

    For each instance, print a line with n integers representing the tasks in a possible order of execution.

    Sample Input

    5 4
    1 2
    2 3
    1 3
    1 5
    0 0

    Sample Output

    1 4 2 5 3
    https://www.bnuoj.com/v3/problem_show.php?pid=18723

    给n个数  再给1~n之间m对关系

    1<2  2<3...................

    输出一种从小到大的排序(只要不矛盾就OK)

    拓扑排序的模板题

    //不包含有向环的有向图为有向无环图(DAG)
    #include<stdio.h>
    #include<string.h>
    #define maxx 1010
    
    int t,n,m;
    int ap[maxx][maxx];
    int vis[maxx],res[maxx];
    
    bool dfs(int u)
    {
        vis[u]=-1;
        for(int i=0; i<n; i++)
            if(ap[u][i])
                if(vis[i]<0)
                    return false;
                else if(!vis[i]&&!dfs(i))
                    return false;
        vis[u]=1;
        res[--t]=u;
        return true;
    }
    
    bool toposort()
    {     t=n;
        memset(vis,0,sizeof(vis));
        for(int i=0; i<n; i++)
            if(!vis[i])
                if(!dfs(i))
                    return false;
        return true;
    }
    
    int main()
    {
        int i,u,v;
        while(scanf("%d%d",&n,&m)&&(n||m))
        {
            memset(ap,0,sizeof(ap));
            while(m--)
            {
                scanf("%d%d",&u,&v);
                ap[u-1][v-1]=1;
            }
            toposort();
            for(i=0; i<n; i++)
            {
                printf("%d ",res[i]+1);
            }
            printf("\n");
        }
        return 0;
    }

    评论
    添加红包

    请填写红包祝福语或标题

    红包个数最小为10个

    红包金额最低5元

    当前余额3.43前往充值 >
    需支付:10.00
    成就一亿技术人!
    领取后你会自动成为博主和红包主的粉丝 规则
    hope_wisdom
    发出的红包
    实付
    使用余额支付
    点击重新获取
    扫码支付
    钱包余额 0

    抵扣说明:

    1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
    2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

    余额充值