09-散列1. Hashing (25)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be "H(key) = key % TSize" where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

Sample Input:
4 4
10 6 4 15
Sample Output:
0 1 4 -

提交代

————————————————

我去,一直竟然卡在了素数的判断上面。

测试点二显然就是1是不是素数的问题,在判断素数的上面,p<2,直接return一个false,非素数。

第二个点是,题目的这么一句话。


Quadratic probing (with positive increments onlyis used to solve the collisions.

这句话,没有在意,就是说冲突处理方式为平方探测。。。。而且是only递增的。


其他的,和老师上面讲的类似。

这里参考了,里面几个函数不太熟悉,

fill函数,我还是比较喜欢memset函数。


代码如下。

#include <iostream>
#include <math.h>
#include <stdlib.h>
#include <memory.h>

using namespace std;
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

struct Hash
{
	bool * Storage;
	int MSize;
};

Hash * Creat(int MSize)
{
	Hash *h=new Hash;
	h->MSize=MSize;
	h->Storage=new bool[MSize];
	fill(h->Storage,h->Storage+h->MSize,false);
	return h;
}

bool isPrim(int p)
{
	int i=0;
	if(p<2) return false;
	for(i=2; i<=sqrt(p); i++)
	{
		if(p%i==0)  return false;
	}
	return true;
}

int Prim(int n)
{
	while(!isPrim(n))
	{
		n++;
	}
	return n;
}

int Hash_Fun(int key, int MSize)
{
	return key%MSize;
}

int main(int argc, char** argv) {

	int MSize,N;
	scanf("%d %d",&MSize,&N);
	
	MSize=Prim(MSize);
	Hash *H=Creat(MSize);

	for(int i=0; i<N; i++)
	{
		int tmp;
		bool flag=false;
		scanf("%d",&tmp);
		for(int j=0; j<N; j++)
		{
			int pos=Hash_Fun(Hash_Fun(tmp,H->MSize)+j*j,H->MSize);
			if(!H->Storage[pos])
			{
				H->Storage[pos]=true;
				flag=true;
				(i==N-1)?printf("%d",pos):printf("%d ",pos);
				break;
			}
		}
		if(flag) continue;
		else
		{
			(i==N-1)?printf("-"):printf("- ");
		}
	}

	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值