1022. Digital Library (30)

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (<=1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print "Not Found" instead.

Sample Input:
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla
Sample Output:
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

提交代

——————————

就知道不会这么简单的,刚刚开始的时候,直接将所有的东西放在结构体内,然后根据id调用sort函数进行排序,然后遍历所有的book,进行匹配,这样肯定会超时的。最大数据量10^4,查询次数10^3,关键字10^3,那么如果线性查找所有关键字,那么将会达到10^10操作,淂超出1000ms。

注意字符数组的输入方式选择。

对于  char a[10],①cin>>a;②cin.getline(a,6);③gets(a);④cin.get(a,6);
若输入"abcd efgh ijkl"回车对应一下结果:
①a[]={'a','b','c','d','\0'}      strlen(a)=4 ; sizeof(a)=10   //遇到空格、制表符、回车即停止
②④a[]={'a','b','c','d',' ','\0'}   strlen(a)=5 ; sizeof(a)=10  //遇到回车停止
③a[]={'a','b','c','d',' ','e','f','g','h',' ','i','j','k','l'}  strlen(a)=14 ; sizeof(a)=10  //溢出错误

在使用cin>>a或cin>>n后,想要使用gets(a)或cin.getline(a,n) 需要先使用cin.ignore()忽略掉空格和回车。
使用ch=cin.get()或cin.get(ch)获取一个字符(可用来寻找回车符'\n')。

姥姥也不会出这么简单的题目。

————

然后,在这里看到了好思路,用map来进行求解,这里直接学习此同学的代码,写的比较漂亮,值得学习。

map的搜索是log(n)的?这样在检索起来会比较快。

对于

#include<iostream>
#include<string>
#include<vector>
#include<algorithm>
#include<map>
#include<sstream>
using namespace std;

int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		//build map
		map<string,std::vector<string> > queryMap[5];
		while(n--)
		{
			getchar();
			string id, title, author, wordList, publisher, year;
			getline(cin, id);
			getline(cin, title); getline(cin, author);
			getline(cin, wordList); 
			getline(cin, publisher); cin>>year;
			queryMap[0][title].push_back(id); queryMap[1][author].push_back(id);
			queryMap[3][publisher].push_back(id); queryMap[4][year].push_back(id);
			istringstream istr(wordList);
			while(!istr.eof())
			{
				string word;
				istr>>word;
				queryMap[2][word].push_back(id);
			}
		}
		//sort first
		for(int i = 0; i < 5; ++i)
		{
			map<string,std::vector<string> >::iterator it;
			for(it=queryMap[i].begin(); it!=queryMap[i].end(); it++)
				sort(it->second.begin(), it->second.end());
		}
		//query
		int m;
		scanf("%d",&m);
		while(m--)
		{
			int index; string q;
			scanf("%d: ", &index);
			getline(cin, q);
			printf("%d: ", index);
			cout<<q<<endl;
			index--;
			map<string,std::vector<string> >::iterator it;
			it = queryMap[index].find(q);
			if(it!=queryMap[index].end())
			{
				std::vector<string> result = queryMap[index][q];
				for(int i = 0; i < result.size(); ++i)
					cout<<result[i]<<endl;
			}
			else printf("Not Found\n");
			
		}
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值