PAT_自测5_Shuffling Machine

题目链接:https://pta.patest.cn/pta/test/17/exam/4/question/264

 

题面:

 

自测5. Shuffling Machine (20)

 

 

Shuffling is aprocedure used to randomize a deck of playing cards. Because standard shufflingtechniques are seen as weak, and in order to avoid "inside jobs"where employees collaborate with gamblers by performing inadequate shuffles,many casinos employ automatic shuffling machines. Your task is tosimulate a shuffling machine.

The machineshuffles a deck of 54 cards according to a given random order and repeats for agiven number of times. It is assumed that the initial status of a card deck isin the following order:

S1, S2, ..., S13,H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

where "S"stands for "Spade", "H" for "Heart","C" for "Club", "D" for "Diamond", and"J" for "Joker". A given order is a permutation of distinctintegers in [1, 54]. If the number at the i-th position is j, it means to movethe card from position i to position j. For example, suppose we only have 5cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, theresult will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again,the result will be: C1, H5, S3, J2, D13.

InputSpecification:

Each input filecontains one test case. For each case, the first line contains a positiveinteger K (<= 20) which is the number of repeat times. Then the next linecontains the given order. All the numbers in a line are separated by a space.

OutputSpecification:

For each test case,print the shuffling results in one line. All the cards are separated by aspace, and there must be no extra space at the end of the line.

Sample Input:

2

36 52 37 38 339 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 1415 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13C5

题目大意:

    原牌顺序是1-54,给定一个位置映射关系,问k次操作后,最后每个位置分别是哪张牌。

解题:

    并不是真正的洗牌,只要记录下映射关系,开一个新数组,存下来,再赋值回去。操作k次后,最后输出即可。

代码:

#include <iostream>
#include <string>
using namespace std;

// int org_pos[54], oper[54], tmp[54];
int org_pos[55], oper[55], tmp[55];

//print card based on the number
string get_card(int x){
	if (x>=0 && x<=13){
		return "S" + to_string(x);
	}else if(x>=14 && x<=26){
		return "H" + to_string(x-13);
	}else if(x>=27 && x<=39){
		return "C" + to_string(x-26);
	}else if(x>=40 && x<=52){
		return "D" + to_string(x-39);
	}else if(x>=53 && x<=54){
		return "J" + to_string(x-52);
	}else{
		return "WRONG";
	}
}

int main()
{
	int round;
	cin >> round;
	//initialize
	for(int i=1; i<=54; i++)
		org_pos[i] = i;
	//input>>oper
	for(int i=1; i<=54; i++)
		cin>>oper[i];

	while(round--){
		for(int i=1; i<=54; i++){
			tmp[oper[i]] = org_pos[i];
		}
		for(int i=1; i<=54; i++){
			org_pos[i] = tmp[i];
		}
	}

	for (int i = 1; i <=54; ++i)
	{
		cout<<get_card(org_pos[i]);		//忘了调用get_card
		if(i!=54)
			cout<<" ";
	}
	return 0;
}

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值