PAT_A1042 Shuffling Machine

模拟洗牌机器的过程,对54张卡牌进行洗牌操作,重复指定次数,并输出结果。输入包含重复次数和洗牌顺序,输出洗牌后的卡牌序列。
摘要由CSDN通过智能技术生成

PAT学习笔记之A1042 Shuffling Machine (20 分)

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13,
H1, H2, …, H13,
C1, C2, …, C13,
D1, D2, …, D13,
J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

思路:

由于输出是花色与数字捆绑输出,所以想到了定义一个char类型card[]数组存放未洗牌前的牌面,对card[]数组根据题目所给花色顺序与数字序列初始化,再定义一个char类型ncard[]数组存放洗牌后的牌面序列;
根据order[]中的对应关系进行洗牌操作,即

strcpy(ncard[order[i]-1],card[i]);

每次洗牌操作后更新card[],即将ncard[]赋值给card[]。

完整代码:

#include <stdio.h>
#include <string.h>

int main() {
    int order[54],i,k,n;
    char card[54][4],ncard[54][4],str[3];
    for(i=0;i<54;i++){
        if(i<13){
            strcpy(card[i], "S");
            sprintf(str, "%d",i+1);
            strcat(card[i], str);
        }
        else if (i<26){
            strcpy(card[i], "H");
            sprintf(str, "%d",i-12);
            strcat(card[i], str);
        }
        else if (i<39){
            strcpy(card[i], "C");
            sprintf(str, "%d",i-25);
            strcat(card[i], str);
        }
        else if (i<52){
            strcpy(card[i], "D");
            sprintf(str, "%d",i-38);
            strcat(card[i], str);
        }
        else{
            strcpy(card[i], "J");
            sprintf(str, "%d",i-51);
            strcat(card[i], str);
        }
    }
    if(scanf("%d",&n)){};
    for(i=0;i<54;i++){
        if(scanf("%d",order+i)){};
    }
    for(k=0;k<n;k++){
        for(i=0;i<54;i++){
            strcpy(ncard[order[i]-1],card[i]);
        }
        for(i=0;i<54;i++){
            strcpy(card[i],ncard[i]);
        }
    }
    for(i=0;i<53;i++){
        printf("%s ",ncard[i]);
    }
    printf("%s\n",ncard[53]);
    return 0;
}

总结与反思:

简单模拟题。关键操作大概在洗牌之处,只需根据题目给出的例子简单模拟即可得出规律。
难到我的是输入与输出格式, char类型与int类型一起输出,我受了题目洗牌的固定思维模式,将牌面一起存放在card[]数组中,但看柳神的代码即可知题目中的花色char和数字int是有规律可循的,可在输出时根据对应关系分开输出,这样就能简化代码,简化思路。

//柳神代码
//c[6] = {"SHCDJ"}
//end[55]保存每一次变换的开始顺序和结束顺序(以1~54的编号存储)
printf("%c%d", c[end[i]/13], end[i]%13+1)

柳神代码参考:
https://blog.csdn.net/liuchuo/article/details/52108161

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值