HDU 1025:Constructing Roads In JGShining's Kingdom(DP)

Constructing Roads In JGShining’s Kingdom

Time limit:1000 ms Memory limit:32768 kB


Problem Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. 

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. 

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. 

For example, the roads in Figure I are forbidden. 

这里写图片描述

In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^ 

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file. 

Output

For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 

Sample Input

2
1 2
2 1
3
1 2
2 3
3 1

Sample Output

Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

题意:

有n个贫穷的城市,n个富裕的城市,每个贫穷的城市都需要某个富裕城市的资源,贫穷的城市在下方排成一条直线,富裕的城市在上方排成一条直线,现在需要为运输资源修路,但是路不能交叉(如图),问最多可以修多少条道路运输资源。

解题思路:

用一个桶排记录贫穷的城市对应富裕的城市,接下来就是一个LIS,在NlogN的复杂度就可以。

Code:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn=500000+5;
int a[maxn];
int dp[maxn];

int main()
{
    int n,ca=1;
    while(scanf("%d",&n)!=EOF)
    {
        int p,r;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&p,&r);
            a[p]=r;
        }
        memset(dp,0,sizeof(dp));
        int len=0;
        for(int i=1;i<=n;i++)
        {
            if(len==0||a[i]>dp[len-1])
            {
                dp[len++]=a[i];
            }
            else
            {
                int p=lower_bound(dp,dp+len,a[i])-dp;
                dp[p]=a[i];
            }

        }

        printf("Case %d:\n",ca++);
        if(len==1)
            printf("My king, at most 1 road can be built.\n");
        else
            printf("My king, at most %d roads can be built.\n",len);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值