HDU 4006:The kth great number(数据结构?)

The kth great number

Time limit:1000 ms Memory limit:65768 kB


Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

题意:

首先输入n,k,接下来如果输入I x,表示插入x这个元素,如果输入Q,表示查询第k大的元素

解题思路:

按理说题目不难,就是想了好久都没想出来orz。我们使用一种容器,插入元素时只保留K个最小的元素就可以了,然后查询的时候就输出最大的那个元素。至于容器,可以选择multiset和优先队列,实测优先队列耗时稍微少点。

Code:

  • 优先队列解法 124ms
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;

priority_queue<int,vector<int> ,greater<int> > Q;

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        while(!Q.empty())
            Q.pop();
        char op;
        for(int i=0; i<n; i++)
        {
            scanf(" %c",&op);
            if(op=='I')
            {
                int num;
                scanf("%d",&num);
                Q.push(num);
                if(Q.size()>k)
                    Q.pop();
            }
            else
            {
                printf("%d\n",Q.top());
            }
        }
    }
    return 0;
}
  • multiset解法 140ms
#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <string>
#include <set>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
typedef long long LL;

multiset<int> S;

int main()
{
    int n,k;
    while(scanf("%d%d",&n,&k)!=EOF)
    {
        S.clear();
        char op;
        for(int i=0; i<n; i++)
        {
            scanf(" %c",&op);
            if(op=='I')
            {
                int num;
                scanf("%d",&num);
                S.insert(num);
                if(S.size()>k)
                    S.erase(S.begin());
            }
            else
            {
                printf("%d\n",*S.begin());
            }
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值