甲级 1007 Maximum Subsequence Sum

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

这道题要我们做的事情就是,得到最大的字串和,并且返回最小的字串的范围,如果所有K个数都是负数,那么它的最大和定义为0

思路就是:遍历整个数组,如果sum的值为负数,我们需要尽可能的贪心,即就是尽可能将加上的负数尽可能的少,所以在这种情况时我们需要舍去这个sum,如果sum > res时,这就证明了此时的这个子串的总和大于之前算过的任何一个子串和,将范围更新为这个子串范围,最后遍历完数组后得到的就是最大的字串

最后注意如果最终结果为负的时候应该输出的是0

直接上代码

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;
int main()
{
    int k;
    cin>>k;
    vector<int>a(k+10);
    int sum = 0,res = -1;
    int left = 0,left1 = 0;
    int right = k - 1;
    for(int i=0;i<k;i++)
    {
        cin>>a[i];
        sum += a[i];
        if(sum < 0)
        {
            sum = 0;
            left1 = i + 1;
        }
        else if(sum > res)
        {
            res = sum;
            right = i;
            left = left1;
        }
    }
    if(res < 0) res = 0;
    cout<<res<<" "<<a[left]<<" "<<a[right];
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值