1122 Hamiltonian Cycle 甲级xp_xht123

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1​ V2​ ... Vn​

where n is the number of vertices in the list, and Vi​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

解题思路:读懂题目就行,理解曼哈顿回路就可解决问题

第一点 起点和终点相同
第二点 路径的每一步都有边
第三点 所有点都要走到
第四点 总点数是n + 1 

知道什么是曼哈顿回路,对于解决这个问题很管用

#include<iostream>
#include<cstring>
#include<vector>

using namespace std;
const int N = 510;
int n , m;
bool g[N][N] , st[N];
vector<int>nodes;

bool check(int u)
{
    //起点和终点相同
    if(nodes[0] != nodes[u - 1]) return false;
    //总点数是n + 1
    if(u != n + 1) return false;
    
    //第二点 路径的每一步都有边
    
    memset(st , false , sizeof st);
    
    for(int i = 0;i < u - 1;i ++)
    {
        st[nodes[i]] = true;
        if(!g[nodes[i]][nodes[i + 1]]) return false;
    }
    //第三点 所有点都要走到
    for(int i = 1;i <= n;i ++)
        if(!st[i]) return false;
    return true;
}

int main()
{
    cin >> n >> m;
    while(m --)
    {
        int a , b;
        cin >> a >> b;
        g[a][b] = g[b][a] = true;
    }
    
    int k;
    cin >> k;
    while(k --)
    {
        int x;
        cin >> x;
        for(int i = 0;i < x;i ++) 
        {
            int num;
            cin >> num;
            nodes.push_back(num);
        }
        
        if(check(x)) puts("YES");
        else puts("NO");
        nodes.clear();
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值