PAT-A-1004 Counting Leaves (30分)【DFS+BFS】

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1
代码如下:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <string.h>
#include <math.h>
using namespace std;
const int maxn=105;
struct node
{
    int level;
    vector<int> child;
}Node[maxn];
int maxLevel=1;//用来记录最深层次,便于遍历输出
int hashTable[maxn]={0};//记录各层叶节点
int n,m;
void BFS(){
    queue<int>q;
    q.push(1);//将根节点入队
    while(!q.empty()){
        int now=q.front();
        q.pop();//弹出队首结点
        maxLevel=max(maxLevel,Node[now].level);
        if(Node[now].child.size()==0){//如果是叶节点
            hashTable[Node[now].level]++;
        }
        for(int i = 0 ; i < Node[now].child.size() ; i ++){
            Node[Node[now].child[i]].level=Node[now].level+1;//让孩子结点的层数加1
            q.push(Node[now].child[i]);
        }
    }
}
//进行初始化,将所有结点的level置位1
void init(){
    for(int i = 0 ; i < maxn ; i ++){
        Node[i].level=1;
    }
}
int main(){
    init();
    scanf("%d%d",&n,&m);
    int parent,k,child;
    for(int i = 0 ; i < m ; i ++){
        scanf("%d%d",&parent,&k);
        for(int j = 0 ; j < k ; j ++){
            scanf("%d",&child);
            Node[parent].child.push_back(child);
        }
    }
    BFS();
    for(int i = 1 ; i <= maxLevel ; i ++){
        printf("%d",hashTable[i]);
        if(i!=maxLevel){
            printf(" ");
        }
    }
    // system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值