PAT-A-1066 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

在这里插入图片描述

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:
5
88 70 61 96 120
Sample Output 1:
70
Sample Input 2:
7
88 70 61 96 120 90 65
Sample Output 2:
88
代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=30;
struct node
{
    int v,height;//v为结点权值,height为当前子树高度
    node *lchild,*rchild;
} *root;
node* newNode(int v){
    node* Node=new node;
    Node->v=v;
    Node->height=1;
    Node->lchild=Node->rchild=NULL;
    return Node;
}
int getHeight(node* root){
    if(root==NULL){
        return 0;
    }
    return root->height;
}
void updateHeight(node* root){
    //max(做孩子节点的的heigh,又孩子结点的height)+1
    root->height=max(getHeight(root->lchild),getHeight(root->rchild))+1;
}
int getBalanceFactor(node* root){
    return getHeight(root->lchild)-getHeight(root->rchild);
}
//左旋
void L(node* &root){
    node* temp=root->rchild;
    root->rchild=temp->lchild;
    temp->lchild=root;
    updateHeight(root);
    updateHeight(temp);
    root=temp;
}
void R(node* &root){
    node* temp=root->lchild;//root的指向结点B temp指向结点A
    root->lchild=temp->rchild;
    temp->rchild=root;
    updateHeight(root);
    updateHeight(temp);
    root=temp;
}
void insert(node* &root , int v){//构造树所以使用引用
    if(root==NULL){//达到空结点,插入
        root=newNode(v);
        return;
    }
    if(v<root->v){             //v比根节点权值小
        insert(root->lchild,v);//在左子树插入
        updateHeight(root);//更新树高
        if(getBalanceFactor(root)==2){
            if(getBalanceFactor(root->lchild)==1){      //LL型
                R(root);
            }else if(getBalanceFactor(root->lchild)==-1){//LR型
                L(root->lchild);
                R(root);
            }
        }
    }else{//v比根节点权值大
        insert(root->rchild,v);//在右子树插入
        updateHeight(root);
        if(getBalanceFactor(root)==-2){
            if(getBalanceFactor(root->rchild)==-1){   //rr型
                L(root);
            }else if(getBalanceFactor(root->rchild)==1){//RL型
                R(root->rchild);
                L(root);
            }
        }
    }
}
//AVL树建立
node* Create(int data[],int n){
    node* root=NULL;
    for(int i = 0 ; i < n ; i ++){
        insert(root,data[i]);
    }
    return root;
}
int main(){
    int n;
    scanf("%d",&n);
    int data[maxn];
    for(int i = 0 ; i < n ; i ++){
        scanf("%d",&data[i]);
    }
    root=Create(data,n);
    printf("%d\n",root->v);
    // system("pause");
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值