【PAT】A1039 Course List for Student

 

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​(≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

解题思路:

  1. 题目大意&样例说明:给出学生数和课程数,在下面单元,给出课程号和选课学生的数目,之后给出学生的姓名;要求给出每一位学生的学科数目,选课编号并以升序列出。
  2. 代码分为4段:首先是输入数据;其次整理输入数据(在输入数据之后直接进行),将学生的姓名转化为id号,这样做的好处是,看到最后要求输出的学生的姓名是给你的,所以只需要把最后学生的姓名转化为id号,取出其中存在vector中的数据即可;然后处理数据,使用vector容器的size()函数得到选课数目,使用getID函数将字符串转化为整型作为数组下标,记录学生选课的课程编号,通过sort()函数得到升序排序;最后按要求输出即可。
  3. 总结:首先,vector<int> selectCourse[N]应作为全体数列放在外面;selectCourse[i][j]表示id号为i的学生,j是插入的顺序;另外sort()函数的应用也有所不同,即sort(selectCourse[id].begin(),selectCourse[id].end(),cmp);也需要格外留意一下;getID()函数中的最后*10+(a[i]-'0'),思考一下*10可以去掉吗?答案是否定的,与思路不同(位数少一位,可以重复发生冲突)。

代码: 

#include <stdio.h>
#include <vector>
#include <algorithm>
#include <iostream>
#include <string.h>
using namespace std;
const int M=40010;
const int N=26*26*26*10+10; 
vector<int> selectCourse[N];  //要放在外面 
int getID(char a[]){
	int id=0;
	for(int i=0;i<3;i++){
		id=id*26+(a[i]-'A');
	}
	id=id*10+(a[3]-'0');
	return id;
}

int main(){
	int m,n,courseID,num,id;
	char name[5];
	scanf("%d%d",&m,&n);
	for(int i=0;i<n;i++){
		scanf("%d%d",&courseID,&num);
		for(int j=0;j<num;j++){
			scanf("%s",name);
			id=getID(name);
			selectCourse[id].push_back(courseID); //第id行插入课程号 
		}
	}
	for(int i=0;i<m;i++){
		scanf("%s",name);
		printf("%s ",name);
		id=getID(name);
		sort(selectCourse[id].begin(),selectCourse[id].end());
		printf("%d",selectCourse[id].size());
		for(int j=0;j<selectCourse[id].size();j++){
			printf(" %d",selectCourse[id][j]);
		}
		printf("\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_之桐_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值