【PAT】A1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

总结: 

  1. 常规题速战速决
  2. 用ans数组来记录每一层叶子结点数是一个很快的办法,也便于输出。这个很重要的一个思想,借助外数组存放答案

代码:

#include <stdio.h>
#include <vector>
using namespace std;
const int maxn=110;
int total,row,hdepth=0;
int ans[maxn];
struct Node{
	int layer;  //记录层数
	vector<int> child; 
}node[maxn];

void DFS(int index,int depth){
	node[index].layer=depth;
	if(node[index].child.size()==0){
		if(node[index].layer>hdepth){
			hdepth=node[index].layer;
		}
		ans[node[index].layer]++;
	}
	for(int i=0;i<node[index].child.size();i++){
		int child=node[index].child[i];
		DFS(child,depth+1);
	}
}
int main(){
	for(int i=0;i<maxn;i++){
		ans[i]=0;
	}
	int id,childNum,child;
	scanf("%d %d",&total,&row);
	for(int i=0;i<row;i++){
		scanf("%d %d",&id,&childNum);
		for(int j=0;j<childNum;j++){
			scanf("%d",&child);
			node[id].child.push_back(child);
		}
	}
	DFS(1,0);  //根结点编号,层数(0或1无关) 

	for(int i=0;i<=hdepth;i++){
		printf("%d",ans[i]);
		if(i<=hdepth-1) printf(" ");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_之桐_

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值