HDU1671 Phone List

字典树水题,我在每一个节点都用了一个used来表示它是否被经过了,也用了一个end标志表示它是否为一个单词的结尾,虽然思路不是最好的,但是也AC了。。。。

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12405    Accepted Submission(s): 4209


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cmath>
using namespace std;
typedef struct trie
{
    trie * next[10];
    bool isend;
    bool used;
};
int ans;
trie * newnode()
{
    trie * a = new trie;
    a->isend = false;
    a->used = false;

    for(int i = 0; i < 10; i++)
    {
        a->next[i] = NULL;
    }

    return a;
}
trie * Insert(trie * root, char a[])
{
    trie * use = root;

    for(int i = 0; a[i]; i++)
    {
        if(use->next[a[i] - '0'] == NULL)
        {
            use->next[a[i] - '0'] = newnode();
        }
        if(use->next[a[i] - '0']->isend==true)
            ans=0;
        if(i!=0)
            use->used=true;
        use = use->next[a[i] - '0'];
    }

    if(use->isend || use->used)
    {
        ans = 0;
    }

    use->isend = true;
    use->used = true;
    return root;
}
void Clear(trie * root)
{
    for(int i = 0; i < 10; i++)
    {
        if(root->next[i] != NULL)
        {
            Clear(root->next[i]);
        }
    }

    delete root;
}
int main()
{
//    freopen("D://input.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        trie* root=newnode();
        ans=1;
        int n;
        scanf("%d",&n);
        char number[12];
        for(int i=0;i<n;i++)
        {
            scanf("%s",number);
            Insert(root,number);
        }
        if(ans)
            printf("YES\n");
        else printf("NO\n");
        Clear(root);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值