hdu5914Triangle+打表

Triangle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 338 Accepted Submission(s): 229

Problem Description
Mr. Frog has n sticks, whose lengths are 1,2, 3⋯n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with
any three of the remaining sticks.

Input
The first line contains only one integer T (T≤20), which indicates the number of test cases.

For each test case, there is only one line describing the given integer n (1≤n≤20).

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.

Sample Input

3
4
5
6

Sample Output

Case #1: 1
Case #2: 1
Case #3: 2

Source
2016中国大学生程序设计竞赛(长春)-重现赛

Recommend
wange2014 | We have carefully selected several similar problems for you: 5932 5931 5930 5929 5928

n个木棒,长度1~n
至少拿走几个才能让剩下的木棒不能组成三角形
打个表。。


#include<bits/stdc++.h>
using namespace std;

int main(){
    int a[22]={0,0,0,0,1,1,2,3,3,4,5,6,7,7,8,9,10,11,12,13,14};
    int t;
    cin>>t;
    for(int cas=1;cas<=t;cas++){
        int n;
        cin>>n;
        cout<<"Case #"<<cas<<": "<<a[n]<<endl;
    }
    return 0;
}
打表代码:
/*
#include<bits/stdc++.h>
using namespace std;

bool san(int n,int z){
    for(int i=1;i<=n;i++){
        for(int j=i+1;j<=n;j++){
            for(int k=j+1;k<=n;k++){
                //cout<<(z>>(i-1))&1<<endl;
                if(!((z>>(i-1))&1)&&!((z>>(j-1))&1)&&!((z>>(k-1))&1)){
                    if(i+j>k) return true;
                }
            }
        }
    }
    return false;
}
int get1(int z){
    int cnt=0;
    while(z){
        if(z&1) cnt++;
        z>>=1;
    }
    return cnt;
}
int main(){
    for(int n=1;n<=20;n++){

        int zt=(1<<n)-1;
        int ans=20;
        for(int i=0;i<=zt;i++){
            if(san(n,i)==false){
                ans=min(ans,get1(i));
                //cout<<n<<" "<<i<<" "<<get1(i)<<endl;
                //break;
            }
        }
        cout<<ans<<",";
    }
}

*/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值