acm_Proud Merchants

题目:

Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.<br>The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.<br>If he had M units of money, what’s the maximum value iSea could get?<br><br>
 

Input
There are several test cases in the input.<br><br>Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.<br>Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.<br><br>The input terminates by end of file marker.<br><br>
 

Output
For each test case, output one integer, indicating maximum value iSea could get.<br><br>
 

Sample Input
  
  
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
  
  
5 11
 

题意:N件商品,钱共有M。。商品的价格为Pi,商品的价值为Vi,然后如果你想购买这件商品手中至少要有Qi元,让求最大能得到的价值。。


想法:动态规划。。方程是dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v)


代码:

#include<stdio.h>  
#include<string.h>  
#include<algorithm>  
#include<iostream>
using namespace std;  
const int MAXN=550;  
struct Node  
{  
    int p,q,v;  
}node[MAXN];
int inline max(int a,int b)
{
    return a>b?a:b;
}
int dp[5500];  
bool cmp(Node a,Node b)  
{  
    return a.q-a.p < b.q-b.p;  
}  
int main()  
{  
    int n,i,m; 
    //freopen("r.txt","r",stdin);
    while(cin>>n>>m)  
    {  
        for(i=0;i<n;i++)  
          cin>>node[i].p>>node[i].q>>node[i].v;  
        sort(node,node+n,cmp);  
        memset(dp,0,sizeof(dp));  
        for(i=0;i<n;i++)  
          for(int j=m;j>=node[i].q;j--)  
            dp[j]=max(dp[j],dp[j-node[i].p]+node[i].v);  
        cout<<dp[m]<<endl;  
    }  
    return 0;  
}


好难。。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值