HDU2088Box of Bricks

Box of Bricks

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13802    Accepted Submission(s): 4600


Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 

Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.
 

Sample Input
  
  
6 5 2 4 1 7 5 0
 

Sample Output
  
  
5
 

根据题目意思,其实我们还要求出其平均数就可以了,然后用其平均数求出比起小的数差多少再相加就得出了最终答案;
但是有一点要注意的是,就是注意控制输出的格式;一开始我一直以为没两次的测试据结果中间有一个空行,是:


6
5 2 4 1 7 5
5

6
6 1 4 0 8 5
7
0
是这样的;在这里纠结了好久,发现根本就不能控制成这样,最后就抱着试一试的心态控制这样的格式:

6
5 2 4 1 7 5
5
6

6 1 4 0 8 5
7
0
提交之后发现AC了;也是醉了;
给出AC代码:
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	int n, a[105];
	int x = 0;
	while (cin >> n)
	{
		x++;
		if (n == 0)break;
		if (x != 1)cout << endl;
		int sum = 0;
		for (int i = 0; i < n; i++)
		{
			cin >> a[i];
			sum += a[i];
		}
		int average;
		average = sum / n;
		int count = 0;
		for (int i = 0; i < n; i++)
		{
			if (a[i] < average)count += average - a[i];
		}
		cout << count << endl;
	}
	return 0;
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值