HDU1161 Eddy's mistakes

Eddy's mistakes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10108    Accepted Submission(s): 5711


Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter. 
 

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
 

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 

Sample Input
  
  
weLcOmE tO HDOj Acm 2005!
 

Sample Output
  
  
welcome to hdoj acm 2005!
 
题目大意:
Eddy 经常写文章,但是他经常犯一个错误,就是一个单词中大小写穿插,比如正常的写法是"computer science" 但是他经常这样写:"coMpUtEr scIeNce",这样的话他的英语老师看作文的时候就会花很多功夫去整理这些,那么现在需要你写个程序帮助下他的英语老师把他的文章中所有的大写翻译成小写;

思路:
只需要用大写的ASCLL码加上其相应的数,就可以得到其对应的小写的ASCLL 码了,其实就是个大小写的转换;

给出AC代码;
#include<iostream>
#include<string>
#include<cstring>
using namespace std;

char Change_str(char x) //将大写字母转换成小写字母;
{
	if (x >= 'A'&&x <= 'Z')return x + 32;
	return x;
}

int main()
{
	char str[1005];
	while (gets(str)&&strcmp(str,""))
	{
		int len = strlen(str);
		for (int i = 0; i < len; i++)
			cout << Change_str(str[i]); 
		cout << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值