Seinfeld

I’m out of stories. For years I’ve been writing stories, some rather silly, just to make simple problems look difficult and complex problems look easy. But, alas, not for this one. 
You’re given a non empty string made in its entirety from opening and closing braces. Your task is to find the minimum number of “operations” needed to make the string stable. The definition for being stable is as follows: 

  1. An empty string is stable.
  2. If S is stable, then {S} is also stable.
  3. If S and T are both stable, then ST (the concatenation of the two) is also stable.

All of these strings are stable: {}, {}{}, and {{}{}}; But none of these: }{, {{}{, nor {}{. 
The only operation allowed on the string is to replace an opening brace with a closing brace, or visa-versa.

Input

Your program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length. 
The last line of the input is made of one or more ’-’ (minus signs.)

Output

For each test case, print the following line: 
k. N 
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.

Sample Input

}{
{}{}{}
{{{}
---

Sample Output

1. 2
2. 0
3. 1

这题的思想比较简单,但是可能会想不到,就是对于每一组括号,总是先出现左括号,后出现右括号,每一组左括号都对应一个右括号。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 4400


char ch[maxn];
int num,no[maxn],n;


void solve(){
    num=0;
    int d=0;
    for(int i=0;i<n;i++){
        if(no[i]==0) d++;
        if(no[i]==1) d--;
        if(d<0){
            no[i]=0;
            num++;
            d=1;
        }
    }
    if(d>0) num+=d/2;
}


int main(){
    int counnt=0;
    while(scanf("%s",&ch)!=EOF){
        if(ch[0]=='-') break;//只要是存在‘-’,即可作为结束条件
        num=0;
        int i;
        for(i=0;i<strlen(ch);i++){
            if(ch[i]=='{') no[i]=0;
            else  no[i]=1;
        }
        n=i;
        solve();
        printf("%d. %d\n",++counnt,num);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值