Crazy tea party

n participants of �crazy tea party� sit around the table. Each minute one pair of neighbors can change their places. Find the minimum time (in minutes) required for all participants to sit in reverse order (so that left neighbors would become right, and right - left).

Input

The first line is the amount of tests. Each next line contains one integer n (1 <= n <= 32767) - the amount of crazy tea participants.

Output

For each number n of participants to crazy tea party print on the standard output, on a separate line, the minimum time required for all participants to sit in reverse order.

Sample Input

3
4
5
6

Sample Output

2
4
6

题意为:n个人围在一桌,每分钟只能是一组相邻的两个人换位置,使所有人做的次序相反(由顺时针改为逆时针),一共所需的最小时间。考察组合排列数学问题

首先考虑n个人坐一排,使倒序,一共需要n*(n-1)/2次,对于每个圆都可以分成数量相近(这样最省时)的两部分,只需要这两部分的人倒序排列即可。

#include<iostream>
using namespace std;


int main(){
    int n,t;
    while(cin>>t){
        while(t--){
            while(cin>>n){
        if(n%2==0) cout<<n/2<<endl;
        else cout<<(n-1)/2<<endl;
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值